httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rodrigo Cunha <rodrigo.root...@gmail.com>
Subject Re: [users@httpd] problem compiling apache
Date Thu, 22 Sep 2016 17:09:38 GMT
Step-by-step, my troubleshoting...rs
Check what comand your use for instaling this openssl
$history |grep -i openssl
$openssl --version
try apt-get remove openssl --purge or other package referal a this
instalation.
Step 2 The search packages ins repository

$sudo apt-cache policy apache2
$sudo apt-cache policy openssl

#######My outputs:##########

$LC_MESSAGES=C sudo apt-cache policy apache2
apache2:
  Installed: 2.4.7-1ubuntu4.9
  Candidate: 2.4.7-1ubuntu4.13
  Version table:
     2.4.7-1ubuntu4.13 0
        500 http://archive.ubuntu.com/ubuntu/ trusty-updates/main amd64
Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64
Packages
 *** 2.4.7-1ubuntu4.9 0
        100 /var/lib/dpkg/status
     2.4.7-1ubuntu4 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
casa-PC ~ $LC_MESSAGES=C sudo apt-cache policy openssl
openssl:
  Installed: 1.0.1f-1ubuntu2.18
  Candidate: 1.0.1f-1ubuntu2.19
  Version table:
     1.0.1f-1ubuntu2.19 0
        500 http://archive.ubuntu.com/ubuntu/ trusty-updates/main amd64
Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64
Packages
 *** 1.0.1f-1ubuntu2.18 0
        100 /var/lib/dpkg/status
     1.0.1f-1ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages
casa-PC ~ $

this comands displayed the packages avaliable in your repositoryes, you
have a set repository wich openssl >1.0.2 version.

for set the repository, make:
apt-get install -t trusty-security apache2=2.4.7-1ubuntu4.13

if your system is centos, i think a yum have this comands.

try, and report please
:)

2016-09-22 11:19 GMT-03:00 Daniel <dferradal@gmail.com>:

> try issuing "make clean" before trying to ./configure and make again.
>
> 2016-09-22 10:37 GMT+02:00 Pavol Eisenberg <pavol.eisenberg@gmail.com>:
>
>> many thanks, do you have any idea how to revert the situation ? I've
>> reinstalled openssl libs to 1.0.2 but the problem remain. Seems like some
>> libs was linked staticaly when openssl 1.1.0 was compiled. Can you guess
>> what should be the best possible way to get rid of this problem ?
>>
>>
>>
>> On Wed, Sep 21, 2016 at 8:54 PM, Daniel <dferradal@gmail.com> wrote:
>>
>>> AFAIK httpd 2.4.x branch is not compatible with  Openssl 1.1.0 yet, as
>>> that openssl version has just been released and many things have changed.
>>> In fact I recall when httpd 2.4.23 was released openssl 1.1.0 was still beta
>>>
>>> 2016-09-21 17:47 GMT+02:00 Rodrigo Cunha <rodrigo.root.rj@gmail.com>:
>>>
>>>> Try get http source code(tarball) from you repository, thys
>>>> compilations They were probably tested by sysadmins operating system.
>>>> In output from you make, this problem probably is a erro in string
>>>> from function main in the source code.
>>>> aparantemente ele não está nomeando o caminho correto dos binarios,
>>>> algo sobre referencias
>>>>
>>>> ab.o: In function `main':
>>>> ab.c:(.text+0x62a8): undefined reference to `SSLv2_client_method'
>>>> ab.c:(.text+0x653c): undefined reference to `CRYPTO_malloc_init'
>>>> collect2: error: ld returned 1 exit status
>>>> Makefile:73: recipe for target 'ab' failed
>>>> make[2]: *** [ab] Error 1
>>>>
>>>>
>>>> -text Translated by google translate;
>>>> "Apparently he is not naming the correct path of the binary, something
>>>> about the main function.
>>>> It does not seem compatibility error, just some binary the ssl is the
>>>> path or a different string of entered in binary.
>>>> It is possible that the ./configure to set the path of your new ssl.
>>>> error seems the main function of the settings.
>>>> Look:
>>>> Makefile: 73: recipe for target 'ab' failed
>>>> target ab failed; "
>>>>
>>>> -Texto traduzido pelo google translate; Original em portugues do Brasil.
>>>> "aparentemente ele não está nomeando o caminho correto dos binarios,
>>>> algo sobre a função main.
>>>> Não parece erro de compatibilidade, apenas algum binario do ssl está
>>>> com o caminho ou com uma string diferente das inseridas no binario.
>>>> É possivel que no ./configure de para setar o caminho do seu novo ssl.
>>>> parece erro da função main sobre as definições.
>>>> veja:
>>>> Makefile:73: recipe for target 'ab' failed
>>>> target ab failed;"
>>>>
>>>> 2016-09-20 16:23 GMT-03:00 Pavol Eisenberg <pavol.eisenberg@gmail.com>:
>>>>
>>>>> httpd-2.4.20
>>>>> httpd-2.4.23
>>>>>
>>>>> I tried also with compiled apr-1.5.2 and aprutil apr-util-1.5.4 but
>>>>> that also not help. Any advise ?
>>>>>
>>>>> On Tue, Sep 20, 2016 at 9:16 PM, Christopher Schultz <
>>>>> chris@christopherschultz.net> wrote:
>>>>>
>>>>>> -----BEGIN PGP SIGNED MESSAGE-----
>>>>>> Hash: SHA256
>>>>>>
>>>>>> Pavol,
>>>>>>
>>>>>> On 9/20/16 3:07 PM, Pavol Eisenberg wrote:
>>>>>> > Hello
>>>>>> >
>>>>>> > After I've tried to upgrade my openssl 1.0.2 (ubuntu default)
to
>>>>>> > Openssl 1.1.0 I cannot compile apache with ssl anymore.I also
>>>>>> > reverse to openssl 1.0.2 but the problem still remain.
>>>>>> >
>>>>>> > Can someone point me how to fix this to have working ssl with
>>>>>> > apache ?
>>>>>> >
>>>>>> > Here is my current compile output :
>>>>>> >
>>>>>> >
>>>>>> > /usr/share/apr-1.0/build/libtool --silent --mode=link
>>>>>> > x86_64-linux-gnu-gcc  -pthread   -L/usr/local/lib -lssl -lcrypto
>>>>>> > \ -o ab  ab.lo       /usr/lib/x86_64-linux-gnu/libaprutil-1.la
>>>>>> > <http://libaprutil-1.la> /usr/lib/x86_64-linux-gnu/libapr-1.la
>>>>>> > <http://libapr-1.la> -lm ab.o: In function `main':
>>>>>> > ab.c:(.text+0x62a8): undefined reference to `SSLv2_client_method'
>>>>>> > ab.c:(.text+0x653c): undefined reference to `CRYPTO_malloc_init'
>>>>>> > collect2: error: ld returned 1 exit status Makefile:73: recipe
for
>>>>>> > target 'ab' failed make[2]: *** [ab] Error 1
>>>>>> >
>>>>>> > many thanks for help
>>>>>>
>>>>>> httpd source version?
>>>>>>
>>>>>> - -chris
>>>>>> -----BEGIN PGP SIGNATURE-----
>>>>>> Comment: GPGTools - http://gpgtools.org
>>>>>> Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/
>>>>>>
>>>>>> iQIcBAEBCAAGBQJX4Yr8AAoJEBzwKT+lPKRYn/kQAIctRZy+WykFxc2oGVFzHyWu
>>>>>> PYFHp2zYlex0RornTV7SbAtvNAn9c6OajUHxHVpOT4Hg4V42VqA/SwvxlTzUPYIm
>>>>>> QuUqml3/uEi/ue0mn/ziCCcfs8jm94H4Wz9jakHD2Mw/TzpiFyhGu1XfXoqNgpxd
>>>>>> vALzIyejcwhHCoXIpjZe4ivCUZZ5WIIqnGLoiOcOOkprvT2TsSLlRyTXhbMOjWpt
>>>>>> tm+FmtoFPiFo721Jp+R5/S/S/7+zhaqfzKXYGqnhfBboEhFhugZF1qbdHP9sflCF
>>>>>> p5sOe22s+IiuIuQ1sIZFVtrG0WCGjdY82UB6NEs3+S7CQXBz0D1JAr7xkIZzQhWm
>>>>>> c1fN8mQEO/VzMNysvWyk3NlVUmkPTxX/8dETkxjCb6VWRnr5s/DPw1HFoh5Ps27e
>>>>>> oCHi95sLDXMheUMjCWJ4OyWh/95JU8fCjfOytdyddhFnPHVamANWS6CPVPtModMU
>>>>>> JJSfyBRKVURtN2pemAEq8tBg8prBH1VnLKCehb+yDBU/8yDuCqpBm3xAHciDjMoH
>>>>>> WMqHs8BfMbB0QKAKOpSGjbBvfyW0TTUqEJPzTuSJYTvYdwcOt22rlyBW81qw7nZk
>>>>>> IoyByEk90lfiiElNaBuhI95lFTU+ZejzekJQz+Ro0ZMS3pP29NLjdfxqMNOAG4fI
>>>>>> XbgGozBpggqp/Jx/OJbj
>>>>>> =/B6C
>>>>>> -----END PGP SIGNATURE-----
>>>>>>
>>>>>> ---------------------------------------------------------------------
>>>>>> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>>>>>> For additional commands, e-mail: users-help@httpd.apache.org
>>>>>>
>>>>>>
>>>>>
>>>>
>>>>
>>>> --
>>>> Atenciosamente,
>>>> Rodrigo da Silva Cunha
>>>>
>>>>
>>>
>>>
>>> --
>>> *Daniel Ferradal*
>>> IT Specialist
>>>
>>> email         dferradal at gmail.com
>>> linkedin     es.linkedin.com/in/danielferradal
>>>
>>
>>
>
>
> --
> *Daniel Ferradal*
> IT Specialist
>
> email         dferradal at gmail.com
> linkedin     es.linkedin.com/in/danielferradal
>



-- 
Atenciosamente,
Rodrigo da Silva Cunha

Mime
View raw message