httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Eissing <stefan.eiss...@greenbytes.de>
Subject Re: [users@httpd] Apache HTTP2 and benchmarking with h2load
Date Thu, 25 Aug 2016 13:06:38 GMT
If you add something like

    LogLevel http2:debug
    LogLevel ssl:debug
    LogLevel core:debug

you should find information about negotiation in your error.log. Strange
that Firefox works and h2load does not. I use the later regularly in my tests.

Looking forward to see some log output...

> Am 25.08.2016 um 14:58 schrieb Max Meyer <redeemerofsouls666@web.de>:
> 
> I am trying to do some benchmarking on different HTTP/2 webservers using "h2load" from
nghttp2.org.
> 
> I configured Apache with HTTP/2 and in wireshark I can see HTTP/2 traffic when connecting
with a browser like firefox.
> When I use h2load it falls back to HTTP/1.1 claiming the server does not support NPN/ALPN.
> --------------
> Example:
> 
> h2load -c1 -n1024 -m1024 myapache
> 
> starting benchmark...
> spawning thread #0: 1 total client(s). 1024 total requests
> TLS Protocol: TLSv1.2
> Cipher: ECDHE-RSA-AES128-GCM-SHA256
> No protocol negotiated. Fallback behaviour may be activated
> Server does not support NPN/ALPN. Falling back to HTTP/1.1.
> Application protocol: http/1.1
> ---------------
> 
> I tested h2load with an nginx installation and there it works fine, so I'm guessing that
it is not a problem on the h2load side.
> 
> My Apache site configuration looks like this.
> 
> <IfModule mod_ssl.c>
>    <VirtualHost _default_:443>
>        ServerAdmin webmaster@localhost
> 
>        DocumentRoot /var/www/html
>        Protocols h2
>        H2Push on
> 
>        ErrorLog ${APACHE_LOG_DIR}/error.log
>        CustomLog ${APACHE_LOG_DIR}/access.log combined
> 
>        SSLEngine on
> 
>        SSLCertificateFile    /etc/ssl/server.crt
>        SSLCertificateKeyFile /etc/ssl/private.key
> 
> 
>        <FilesMatch "\.(cgi|shtml|phtml|php)$">
>                SSLOptions +StdEnvVars
>        </FilesMatch>
>        <Directory /usr/lib/cgi-bin>
>                SSLOptions +StdEnvVars
>        </Directory>
>    </VirtualHost>
> </IfModule>
> 
> Apache Version: 2.4.23
> Openssl: 1.0.2h
> 
> Does anyone have an idea what might be the problem?
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message