httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Croci <andrea.cr...@gmx.de>
Subject Re: [users@httpd] Apache LoadBalancer goes into 302 infinite loop
Date Mon, 13 Jun 2016 13:57:58 GMT
Just my two cents: Directives

Order Allow,Deny
Allow from all

are typical of 2.2.x. Although they can be used in 2.4.x, I'm not sure 
it's a good idea. Any reason for not replacing them with the "Require" 
directive?

On 13.06.2016 15:44, Jim Jagielski wrote:
> 2.4.2 is quite old, and there have been numerous fixes and
> improvements to the reverse proxy and load-balancer code
> since then... Is upgrading to 2.4.20 an option?
>
>> On Jun 13, 2016, at 9:39 AM, Baruch Volkov <edabxv@gmail.com> wrote:
>>
>> I do see thousandths posts on Apache LoadBancer and quite a few on infinite loop
with 302, but so far could not be able to fix my issue and would appreciate a comment/suggestion.
>>
>> I have installed Apache/2.4.2 (Win64) with the following configuration:
>>
>> ProxyPass /rcm59018ora balancer://mycluster/rcm59018ora
>> <Location /balancer-manager>
>> SetHandler balancer-manager
>> AuthType Basic
>> AuthName "Balancer Manager"
>> AuthUserFile "D:\Apache2.4\conf\.htpasswd"
>> Require valid-user
>> SetEnvIf X-Forwarded-Proto https HTTPS=on
>> </Location>
>> <Proxy balancer://mycluster stickysession=JSESSIONID>
>> BalancerMember ajp://nyvmcs6:9011/rcm59018ora route=server1
>> BalancerMember ajp://nyvmcs6:9012/rcm59018ora route=server2
>> ProxySet lbmethod=byrequests
>> Order Allow,Deny
>> Allow from all
>> SetEnvIf X-Forwarded-Proto https HTTPS=on
>> </Proxy>
>> StartUp log:
>>
>> [Sun Jun 12 08:38:25.733749 2016] [mpm_winnt:notice] [pid 7060:tid 584] AH00455:
Apache/2.4.2 (Win64) configured -- resuming normal operations
>> [Sun Jun 12 08:38:25.734725 2016] [mpm_winnt:notice] [pid 7060:tid 584] AH00456:
Server built: May 11 2012 20:42:30
>> [Sun Jun 12 08:38:25.734725 2016] [core:notice] [pid 7060:tid 584] AH00094: Command
line: 'D:\\Apache2.4\\bin\\httpd.exe -d D:/Apache2.4 -f D:\\Apache2.4\\conf\\httpd.conf -d
D:\\Apache2.4\\.'
>> [Sun Jun 12 08:38:25.734725 2016] [mpm_winnt:notice] [pid 7060:tid 584] AH00418:
Parent: Created child process 3332
>> [Sun Jun 12 08:38:26.033565 2016] [mpm_winnt:notice] [pid 3332:tid 540] AH00354:
Child: Starting 64 worker threads.
>> Two Apache Tomcat/7.0.47 with following configuration:
>>
>> <Connector port="9011" protocol="AJP/1.3" redirectPort="8445" />
>>
>> <Engine name="Catalina" defaultHost="localhost" jvmRoute="server1">
>> and
>>
>> <Connector port="9012" protocol="AJP/1.3" redirectPort="8446" />
>>
>> <Engine name="Catalina" defaultHost="localhost" jvmRoute="server2">
>> Startup logs:
>>
>> INFO: Starting ProtocolHandler ["ajp-apr-9011"]
>> Jun 12, 2016 7:50:13 AM org.apache.catalina.startup.Catalina start
>>
>> INFO: Starting ProtocolHandler ["ajp-apr-9012"]
>> Jun 12, 2016 7:50:13 AM org.apache.catalina.startup.Catalina start
>> Whenever I try to access - http://nyvmcs6/rcm59018ora it hangs and I see in Apache
log endless:
>>
>> xxx.xxx.xxx.xxx - - [12/Jun/2016:08:39:22 -0400] "GET /rcm59018ora HTTP/1.1" 302
-
>> xxx.xxx.xxx.xxx - - [12/Jun/2016:08:39:22 -0400] "GET /rcm59018ora/acegi/acegilogin.jsp
HTTP/1.1" 302 -
>> xxx.xxx.xxx.xxx - - [12/Jun/2016:08:39:22 -0400] "GET /rcm59018ora/acegi/acegilogin.jsp
HTTP/1.1" 302 -
>>
>> xxx.xxx.xxx.xxx - is my machine from where I access
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message