httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Muller <jmul...@ARCcorp.com>
Subject RE: [users@httpd] Issues migrating Weblogic proxies from Sun One 6.1 to Apache 2.4
Date Mon, 20 Jun 2016 15:31:03 GMT

 Thanks for the response !  This is very informative.  I am going to investigate this further.
 I do have a ticket open with Oracle Support, unfortunately he has not been that helpful yet.
 That is one of the reasons I decided to join this list.  I am very impressed with the breadth
of Apache knowledge out there, so I am hopeful the Apache collective can help me resolve this.

-Joe


-----Original Message-----
From: Mike Rumph [mailto:mike.rumph@oracle.com] 
Sent: Monday, June 20, 2016 10:45 AM
To: users@httpd.apache.org
Subject: Re: [users@httpd] Issues migrating Weblogic proxies from Sun One 6.1 to Apache 2.4

Hello Joe,

I am not in a position to offer an official Oracle statement for your situation.
But I do work closely with the owners of the WLS plug-ins.

Here is an initial evaluation from one of the developers:

"WRITE_ERROR_TO_CLIENT is typically seen when there is an error writing the response to the
client (WLS plug-in client). This usually occurs when the user sends a request, but closes
the browser (or hits a stop
button) before the response is received by the client. In such a scenario, from the plug-in
perspective, whenever response is received from WLS, it cannot relay it to the client as the
connection is broken, and it logs WRITE_ERROR_TO_CLIENT error. This is usually a harmless
error. If the above is not true (closing the browser etc), then it may be possible that the
client timeout is too low (or lower than the WLS response time for the request). In such cases,
the timeout needs to be increased. I am not aware of what parameters to look out for here,
but mod_reqtimeout may be a good beginning."

I hope that this is helpful to you.
For more specific details, you would still need to contact official Oracle support channels.

Thanks,

Mike

On 6/17/2016 7:30 AM, Joe Muller wrote:
> I am working on a project to migrate all our IPlanet 6.1 SP19 webserver proxies (formerly
Sun One) to Apache 2.4, since IPlanet 6.1 does not support TLS 1.2 and IPlanet 7.0 is being
EOL. Our backend application servers are Weblogic 9.2 / Weblogic 12c. The IPlanet proxies
have performed FLAWLESSLY for over 10 years, despite the product being no longer supported
and their WL Plug-in not officially supported with Weblogic 12c.
>
>   However now that we are trying to use a more supported configuration (self-compiled
Apache 2.4.18 running Weblogic Server Plugin 12.1.3) we are constantly seeing these errors,
which results in performance degradation for our applications, and in some cases I think maybe
even lost data.
>
>
>   [Tue Jun 14 09:27:36.239682 2016] [weblogic:error] [pid 12513:tid 
> 140185150932736] [client 10.165.254.1:28171] <1251314659108487> Write 
> to the client failed: calling URL::close at line 559 of BaseProxy.cpp, 
> referer: https://intgalf.xyz.com/ALFA/selectFileType.do?fileType=O1MM
>
>   [Tue Jun 14 09:27:36.239747 2016] [weblogic:error] [pid 12513:tid 140185150932736]
[client 10.165.254.1:28171] <1251314659108487> **
>   *****Exception type [WRITE_ERROR_TO_CLIENT] raised at line 560 of 
> BaseProxy.cpp, referer: 
> https://intgalf.xyz.com/ALFA/selectFileType.do?fileType=O1MM
>
>   [Tue Jun 14 09:27:36.239952 2016] [weblogic:error] [pid 12513:tid 
> 140185150932736] [client 10.165.254.1:28171] <1251314659108487> 
> request 
> [/ALFA/servlet/DecryptDownload?linkName=al_o1mm_carr20150630.csv] did 
> NOT process successfully.................., 
> referer:https://intgalf.xyz.com/ALFA/selectFileType.do?fileType=O1MM
>
>
>
>   Our topology is like this:
>
>   Client Browser <--> Firewall <--> Load Balancer <--> Web Proxies

> <--> Firewall <--> Weblogic Application Servers
>
>   Oracle support suggested as work around that we increase WLSocketsTimeOut in the plug-in,
but I think that only masks the issue, as we still the errors.
>
>   We did a network trace and it looks like the Apache plug-in is pre-maturely closing
the connection to the WL server, but I can't be certain. We know that our firewall is not
responsible.
>
>   Any ideas ? I thought Apache would work better then Sun One, but this has been the
opposite. Is there some fundamental webserver tunable parameter that is so different between
out of the box Sun One and out of the box Apache that could be causing this ?
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message