httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Jagielski <...@jaguNET.com>
Subject Re: [users@httpd] mod_proxy_wstunnel with Unix domain sockets
Date Sun, 22 May 2016 18:51:58 GMT
Hmmm... let me look. 

What version of httpd are you using?

> On May 21, 2016, at 3:43 PM, Michael Fladischer <michael@fladi.at> wrote:
> 
> Hi folks,
> 
> I have a Python ornado base websocket application that listens on a
> Unix domain socket. It was initially written to work with nginx as its
> frontend webserver.
> 
> Now i'm trying to make it work with Apache but it seems that
> mod_proxy_wstunnel is not meant to work with Unix domain sockets.
> 
> What I tried so far in my configuration:
> 
> ProxyPass "/ws" "unix:/tmp/app.sock|ws://example.com/ws"
> 
> When I try to call this websocket endpoint with curl this shows up in
> the Apache error log:
> 
> AH01144: No protocol handler was valid for the URL /ws. If you are
> using a DSO version of mod_proxy, make sure the proxy submodules are
> included in the configuration using LoadModule.
> 
> There seems to be a problem with URL parsing somewhere in the proxy
> system. mod_proxy.so and mod_proxy_wstunnel.so are both loaded.
> 
> Does anyone have an idea what needs to be changed to make this work?
> 
> Cheers,
> -- 
> Michael Fladischer
> Fladi.at
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message