httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Timo Lotterbach <Timo.Lotterb...@bmw-carit.de>
Subject [users@httpd] Need Help with Proxy Setup
Date Tue, 10 May 2016 10:17:40 GMT
Hi everyone,

I have some trouble setting up a proxy to a backend server, which
itself is only accessible using another http proxy with authentication.
Required setup looks like this:

    <my_server>/backend  ->  user:pass@proxy:port  -> backend/path

Access from <my_server> was tested this way:

    curl --proxy-basic -k -v \
         --proxy http://<user>:<pass>@<proxy>:<port> \
         https://<backend>/path

I already tried several settings based on my limited google
search results, but these did not succeed so far.
My current config snippet (failed tries left in intentionally):

    ProxyRequests off
    ProxyVia on
    ProxyPreserveHost on
    SSLProxyEngine on
    SSLProxyVerify none
    SSLProxyCheckPeerCN off
    SSLProxyCheckPeerName off
    SSLProxyCheckPeerExpire off
    
    <Proxy *>
        Order deny,allow
        Allow from all
    </Proxy>

    ProxyPass        "/backend/" "https://<backend>/<path>/"
    ProxyPassReverse "/backend/" "https://<backend>/<path>/"

    <Location "/backend/">
        #AuthType basic
        #AuthBasicAuthoritative Off
        #SetEnv proxy-chain-auth On
        #ProxyRemote "https://<backend>" "http://<proxy>:<port>"
        SetEnv HTTPS_PROXY=http://<user>:<pass>@<proxy>:<port>
        Order deny,allow
        Allow from all
    </Location>


Any help is much appreciated.

Thanks, Timo

Mime
View raw message