httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chandran Manikandan <tech2m...@gmail.com>
Subject [users@httpd] My webmail is not working
Date Fri, 01 Apr 2016 12:04:40 GMT
Dear Lists,

I have running Centos 6.6 64 bit system,
I have updated the packages today through webmin.
After updated the packages my webmail is not working it say like below
error in my system log.

Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that
RewriteRule directive is forbidden: /usr/share/squirrelmail/favico

Below error show when i start the http service.

Starting httpd: [Fri Apr 01 19:55:47 2016] [warn] The Alias directive in
/etc/httpd/conf/squirrelmail.conf at line 3 will probably never match
because it overlaps an earlier Alias.

Browser shown below error.
Forbidden

You don't have permission to access /webmail/ on this server.

 /etc/httpd/conf/squirrelmail.conf file below.

<IfModule mod_alias.c>

Alias /webmail /usr/share/squirrelmail/
</IfModule>

<Directory /usr/share/squirrelmail>
  Options SymLinksIfOwnerMatch
  DirectoryIndex index.php
  Options Indexes MultiViews
   AllowOverride None
  Order allow,deny
  allow from all
</Directory>

/etc/httpd/conf.d/squirrelmail.conf

#
# SquirrelMail is a webmail package written in PHP.
#

Alias /webmail /usr/share/squirrelmail

<Directory "/usr/share/squirrelmail/plugins/squirrelspell/modules">
  Deny from all
</Directory>

# this section makes squirrelmail use https connections only, for this you
# need to have mod_ssl installed. If you want to use unsecure http
# connections, just remove this section:
<Directory /usr/share/squirrelmail>
  RewriteEngine  on
  RewriteCond    %{HTTPS} !=on
  RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}
</Directory>

httpd.conf

<VirtualHost xxx.xxx.xxx.xx>
   ServerName mail.xxxx.com
   ServerAlias xxxx.com/webmail
   ServerAdmin postmaster@xxxx.com
   DocumentRoot /usr/share/squirrelmail
   ErrorLog logs/mail.xxxx.com-error_log
   TransferLog logs/mail.xxxx.com-access_log
</VirtualHost>

Could anyone help me to fix my issue.

-- 
*Thanks,*
*Manikandan.C*
*System Administrator*

Mime
View raw message