httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roland Szűcs <roland.sz...@bookandwalk.com>
Subject [users@httpd] What is wrong with my virtual host setting
Date Sun, 10 Apr 2016 14:31:55 GMT
Hi folks,

I use Apache 2.4 and I installed a Glassfish application server behind it.
I use mod_jk modul as the dynamic content has to be handled by Glassfish
and my static content (wordpress blog) is handled by Abapche.

My test domain is: muveltnep.hu

My conf file for virtual host looks like this:
<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    ServerName muveltnep.hu
    ServerAlias www.muveltnep.hu
    DocumentRoot
/home/glassfish/glassfish/domains/domain1/applications/muveltnepbasic
    JkMount /* muvnepworker
    JkUnMount /blog/* muvnepworker
    <Directory
/home/glassfish/glassfish/domains/domain1/applications/muveltnepbasic/blog>
Options Indexes FollowSymLinks MultiViews
Require all granted
AddHandler php5-script php
    </Directory>
    ErrorLog /home/glassfish/glassfish/domains/domain1/logs/error.log
    CustomLog /home/glassfish/glassfish/domains/domain1/logs/access.log
combined
</VirtualHost>

The following erros are occured:
1. If I type muveltnep.hu I got 404 response
2. If I type muveltnep.hu/muveltnepbasic I got the right index.xhtml and
works properly
3. If I type muveltnep.hu/blog where there is an index.php of my wordpress,
I Got: /blog/index.xhtml Not Found in ExternalContext as a Resource.

Anybody can help me to find my mistakes in the configuration?

<https://www.linkedin.com/pub/roland-sz%C5%B1cs/28/226/24/hu> Roland Szűcs
<https://www.linkedin.com/pub/roland-sz%C5%B1cs/28/226/24/hu> Connect with
me on Linkedin <https://www.linkedin.com/pub/roland-sz%C5%B1cs/28/226/24/hu>
<https://bookandwalk.hu/>
CEO Phone: +36 1 210 81 13
Bookandwalk.hu <https://bokandwalk.hu/>

Mime
View raw message