httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yehuda Katz <yeh...@ymkatz.net>
Subject Re: [users@httpd] issue during installing httpd-2.0.63
Date Thu, 14 Apr 2016 23:22:14 GMT
I have never built 2.0 at all or any version on AIX, so other than the wiki
and documentation (which you likely already read - and if not, you should),
I can't personally help.

Plus whatever or whomever requires that version needs an update too.

- Y

Sent from a gizmo with a very small keyboard and hyperactive autocorrect.
On Apr 14, 2016 6:52 PM, "Sandeep Acharya" <sandeepacharya1983@gmail.com>
wrote:

> Hello Yehuda,
>
> Yes it is required for an SAP Content Server 6.5 installation.. Though I
> can us higher version but this is the requirement.
>
> Can you please assist me on this.
>
> regards,
> Sandeep
>
> On Fri, Apr 15, 2016 at 4:08 AM, Yehuda Katz <yehuda@ymkatz.net> wrote:
>
>> Is there a reason you are building 2.0? The last release was in 2013 and
>> it is likely not secure.
>>
>> For 2.2 or 2.4, have you read this:
>> https://wiki.apache.org/httpd/AIXPlatform
>>
>> - Y
>>
>> Sent from a gizmo with a very small keyboard and hyperactive autocorrect.
>> On Apr 14, 2016 6:21 PM, "Sandeep Acharya" <sandeepacharya1983@gmail.com>
>> wrote:
>>
>>> Hello team,
>>>
>>> I am facing issue during installation of httpd-2.0.63 in IBM AIX 7.1.
>>>
>>> I am using the xlc_r compiler to configure. The onfiguration is
>>> sucessfull. while  I am issuing the "make" the shared libraries inside the
>>> module location generated with ".la" extension. But these are suppose to
>>> generate with ".so" extension. So when I am starting the "apachectl start"
>>> command. It is looking for "mod_access.so" and don't locate the file as
>>> this is generated with "mod_access.la" and starting of apache service
>>> fails.
>>>
>>> The libtool here we are using is 1.5.
>>>
>>> I am using below env variable and configure command to complie apache.
>>>
>>> export CC=xlc_r
>>> export CXX=xlC_r
>>> export CFLAGS="-q64"
>>> export LDFLAGS="-b64"
>>> export EXTRA_LDFLAGS_SHLIB="-b64"
>>> export OBJECT_MODE=64
>>>
>>> ./configure --prefix=/ContentServer/apache --enable-so
>>> --enable-mods-shared=most --with-mpm=prefork
>>>
>>>
>>> Please assist me to get this resolved.
>>> --
>>> Sandeep Acharya
>>>
>>>
>
>
> --
> Sandeep Acharya
> Patni Computer Systems Ltd.
>

Mime
View raw message