httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Kerry.Quin...@thomsonreuters.com>
Subject [users@httpd] HEADERNAME
Date Wed, 06 Apr 2016 12:57:24 GMT
I have a simple homepage which loads with an index.html file fine.

What I'd like is for the sub-directories to all display the same header, loaded from just
one file. This is the bit I'm having problems with.

I've tried a few variations some I got of the web, and have so far and no success.
All my files are under the specified ServerRoot directory.

At the moment my httpd.conf reads:

LoadModule autoindex_module modules/mod_autoindex.so
...
Options Indexes FollowSymLinks
...
<IfModule dir_module>
    DirectoryIndex index.html
</IfModule>

<IfModule mod_autoindex>
    HeaderName head.html
</IfModule>


I've tried enabling FancyIndexing but that didn't seem to work either, though I didn't feel
confident I was setting it up correctly. I have also tried with the complete path specified
and popping the HEADERNAME underneath the Options line without a module specified as this
was in a lot of formats on the web but that didn't work anyway I tried it either.

Navigating to 'mywebpage.com' loads the correct index.html page and 'mywebpage.com/head.html'
loads what I hope my header to look like.

What am I doing wrong? Something simple I'm sure.


________________________________

This e-mail is for the sole use of the intended recipient and contains information that may
be privileged and/or confidential. If you are not an intended recipient, please notify the
sender by return e-mail and delete this e-mail and any attachments. Certain required legal
entity disclosures can be accessed on our website.<http://site.thomsonreuters.com/site/disclosures/>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message