httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yann Ylavic <ylavic....@gmail.com>
Subject Re: [users@httpd] .so modules not being created Apache 2.4.18
Date Tue, 29 Mar 2016 18:52:39 GMT
On Tue, Mar 29, 2016 at 7:52 PM, Leonay Wynn <lwkj328@gmail.com> wrote:
> I need to upgrade from 2.2 to to 2.4
>
> i used  ./configure --prefix=/apps/httpd --enable-ssl
> --with-ssl=/usr/local/ssl --with-mpm=worker --enable-module=headers
>
> as well as
>  ./configure --prefix=/apps/httpd --enable-so --enable-ssl
> --with-ssl=/usr/local/ssl --with-mpm=worker --enable-module=headers

Doesn't this create (at least) the mod_ssl.so file in
/apps/httpd/modules/ directory?

For mod_headers.so, as I said in the other thread, the correct way to
enable the build of a module is --enable-<module_name> (for
mod_<module_name>.so), thus for mod_header: --enable-headers.

I think shared modules (i.e. .so files) are used by default with this
method, but otherwise you could specify it explicitely:
--enable-ssl=shared --enable-headers=shared.

So the complete command should be something like:
$ ./configure --prefix=/apps/httpd --enable-so --enable-ssl=shared
--enable-headers=shared --with-ssl=/usr/local/ssl --with-mpm=worker

Also, please note the modules are really installed once you do the
usual "make && sudo make install" after the above "./configure".

Regards,
Yann.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message