httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luca Toscano <toscano.l...@gmail.com>
Subject Re: [users@httpd] Apache won't start after install on Unix-like system
Date Fri, 18 Mar 2016 16:33:22 GMT
Hello!

My understanding from the error message is that you have the wrong dynamic
library loaded. Try the following command (with your http path):

otool -L /usr/sbin/httpd
/usr/sbin/httpd:
/usr/lib/libpcre.0.dylib (compatibility version 1.0.0, current version
1.1.0)
/usr/lib/libaprutil-1.0.dylib (compatibility version 4.0.0, current version
4.0.0)
/usr/lib/libexpat.1.dylib (compatibility version 7.0.0, current version
7.2.0)
/usr/lib/libiconv.2.dylib (compatibility version 7.0.0, current version
7.0.0)
/usr/lib/libsqlite3.dylib (compatibility version 9.0.0, current version
216.0.0)
/System/Library/Frameworks/LDAP.framework/Versions/A/LDAP (compatibility
version 1.0.0, current version 2.4.0)
/usr/lib/libapr-1.0.dylib (compatibility version 5.0.0, current version
5.8.0)
/usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current version
1225.1.1)

Using the equivalent of LD_PRELOAD in Mac Os (
https://blogs.oracle.com/DatabaseEmporium/entry/where_is_ld_preload_under)
you should be able to add the correct library (latest APR) and let httpd
run.

Let me know!

Luca


2016-03-18 17:17 GMT+01:00 Roparzh Hemon <roparzhhemon@gmail.com>:

> Thanks for your feedback. The question in the StackExchange link you
> gave indeed has an error message resembling mine closely. But I didn't
> use homebrew and the answers in the StackExchange link do not apply to
> my case.
>
> Would you mind telling me what combination of words you tried in
> Google ? So I could try some variations on them
>
> On Fri, Mar 18, 2016 at 5:00 PM, Yehuda Katz <yehuda@ymkatz.net> wrote:
> > Are you running on mac? A quick Google search shows several
> possibilities,
> > all homebrew related.
> >
> >
> http://stackoverflow.com/questions/31036704/starting-apache-httpd-with-homebrew-php55-dyld-library-not-loaded-usr-local
> >
> > - Y
> >
> > On Fri, Mar 18, 2016 at 11:43 AM, Roparzh Hemon <roparzhhemon@gmail.com>
> > wrote:
> >>
> >> I get the following error message :
> >>
> >> $ bin/apachectl -k start
> >> dyld: Library not loaded: /lib/libaprutil-1.0.dylib
> >>   Referenced from: /bin/httpd
> >>   Reason: Incompatible library version: httpd requires version 6.0.0
> >> or later, but libaprutil-1.0.dylib provides version 4.0.0
> >> ../bin/apachectl: line 79: 93130 Trace/BPT trap: 5       $HTTPD "$@"
> >> $
> >>
> >> What is happening ? How can I fix this ?
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> >> For additional commands, e-mail: users-help@httpd.apache.org
> >>
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>

Mime
View raw message