httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luca Toscano <toscano.l...@gmail.com>
Subject Re: [users@httpd] TLSv1.2
Date Sat, 26 Mar 2016 09:01:07 GMT
Hi!

2016-03-25 17:23 GMT+01:00 Leonay Wynn <lwkj328@gmail.com>:

> HI,
>
> I'm running RHEL 5.3. I upgraded my httpd version to Apache 2.4.18.
> configured with this: $ ./configure --prefix=/apps/httpd --enable-ssl
> --with-mpm=worker --enable-module=headers --enable-shared=headers
>
> All works well.
>
> I also installed OpenSSL 1.0.2g . I replaced my system installed openssl
> binary with the OpenSSL 1.0.2g.
>
> I updated my httpd-ssl.conf with
> SSLCipherSuite "EECDH+ECDSA+AESGCM EECDH+aRSA+AESGCM EECDH+ECDSA+SHA384
> EECDH+ECDSA+SHA256 EECDH+aRSA+SHA384 EECDH+aRSA+SHA256 EECDH+aRSA+RC4 EECDH
> EDH+aRSA RC4 !aNULL !eNULL !LOW !3DES !MD5 !EXP
> !PSK !SRP !DSS"
> SSLProtocol All -SSLv2 -SSLv3 +TLSv1.2
>
> when I try to start httpd it complains:
>
> SSLProtocol: Illegal protocol 'TLSv1.2'
>
> does anyone have a procedure to make this work or know what I'm doing
> incorrectly?
>

httpd is not picking up the new SSL lib (not binary), you could try with
the configure option --with-ssl=DIR to instruct mod_ssl.

Luca

Mime
View raw message