httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From o...@arcor.de
Subject Re: [users@httpd] Environment variable set by "apr_env_set()" not accesible by C function "getenv()" within CGI program
Date Fri, 18 Mar 2016 15:09:35 GMT
On Thu, Mar 17, 2016 at 8:47 PM, Eric Covener wrote:
> On Thu, Mar 17, 2016 at 3:38 PM,  <obsd@arcor.de> wrote:
>> Hi,
>>
>> I have an Apache modul where I set an environment variable:
>>
>> apr_env_set("FOO", "BAR", ...);
>>
>> This variable is accesible by PHP:
>>
>> <?php
>>     print(getenv("FOO")); // --> BAR
>> ?>
>>
>> but not by a simple CGI program written in C:
>>
>> #include <stdio.h>
>> #include <stdlib.h>
>
> The environment used for a CGI is not the environment of httpd.  You
> can modify it by adding entries to r->subprocess_env.
>
> Only some very specific vars are copied from httpds environment to the
> CGI, + the subprocess_env entries.
> --
> Eric Covener
> covener@gmail.com
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org

Hi,

many thanks.

apr_table_setn(r->subprocess_env, "FOO", "BAR")

works perfectly.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message