httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bumbernick, Tom" <tom.bumbern...@hpe.com>
Subject RE: [users@httpd] Help Needed to add Connectiontimeout to ProxyPass
Date Mon, 25 Jan 2016 18:57:25 GMT
Like this?  This is from the internal non-client side…

[Mon Jan 25 12:37:43.269317 2016] [proxy_balancer:debug] [pid 9456:tid 2472] mod_proxy_balancer.c(669):
[client nnn.nnn.nnn.nnn:23896] AH01176: proxy_balancer_post_request for (balancer://screens_dev),
referer: https://servername.com:20443/
[Mon Jan 25 12:37:43.675592 2016] [ssl:debug] [pid 9456:tid 2472] ssl_engine_kernel.c(347):
[client nnn.nnn.nnn.nnn:23896] AH02034: Subsequent (No.3) HTTPS request received for child
246 (server servername.com:443), referer: https://servername.com:20443/
[Mon Jan 25 12:37:43.675592 2016] [authz_core:debug] [pid 9456:tid 2472] mod_authz_core.c(834):
[client nnn.nnn.nnn.nnn:23896] AH01628: authorization result: granted (no directives), referer:
https://servername.com:20443/
[Mon Jan 25 12:37:43.675592 2016] [lbmethod_byrequests:debug] [pid 9456:tid 2472] mod_lbmethod_byrequests.c(95):
AH01207: proxy: Entering byrequests for BALANCER (balancer://screens_dev)
[Mon Jan 25 12:37:43.675592 2016] [lbmethod_byrequests:debug] [pid 9456:tid 2472] mod_lbmethod_byrequests.c(142):
AH01208: proxy: byrequests selected worker "https://servername.com:8443/Client_Dev" : busy
0 : lbstatus 0
[Mon Jan 25 12:37:43.675592 2016] [proxy_balancer:debug] [pid 9456:tid 2472] mod_proxy_balancer.c(614):
[client nnn.nnn.nnn.nnn:23896] AH01172: balancer://screens_dev: worker (https://servername.com:8443/Client_Dev)
rewritten to https://servername.com:8443/Client_Dev/RPS, referer: https://servername.com:20443/
[Mon Jan 25 12:37:43.675592 2016] [proxy:debug] [pid 9456:tid 2472] proxy_util.c(1783): AH00924:
worker https://servername.com:8443/Client_Dev shared already initialized
[Mon Jan 25 12:37:43.675592 2016] [proxy:debug] [pid 9456:tid 2472] proxy_util.c(1825): AH00926:
worker https://servername.com:8443/Client_Dev local already initialized
[Mon Jan 25 12:37:43.675592 2016] [proxy:debug] [pid 9456:tid 2472] mod_proxy.c(1158): [client
nnn.nnn.nnn.nnn:23896] AH01143: Running scheme balancer handler (attempt 0), referer: https://servername.com:20443/
[Mon Jan 25 12:37:43.675592 2016] [proxy:debug] [pid 9456:tid 2472] proxy_util.c(2158): AH00942:
HTTPS: has acquired connection for (servername.com)
[Mon Jan 25 12:37:43.675592 2016] [proxy:debug] [pid 9456:tid 2472] proxy_util.c(2212): [client
nnn.nnn.nnn.nnn:23896] AH00944: connecting https://servername.com:8443/Client_Dev/RPS to servername.com:8443,
referer: https://servername.com:20443/
[Mon Jan 25 12:37:43.675592 2016] [proxy:debug] [pid 9456:tid 2472] proxy_util.c(2421): [client
nnn.nnn.nnn.nnn:23896] AH00947: connected /Client_Dev/RPS to servername.com:8443, referer:
https://servername.com:20443/
[Mon Jan 25 12:37:43.909945 2016] [proxy:debug] [pid 9456:tid 2472] proxy_util.c(2173): AH00943:
https: has released connection for (servername.com)
[Mon Jan 25 12:37:43.909945 2016] [proxy_balancer:debug] [pid 9456:tid 2472] mod_proxy_balancer.c(669):
[client nnn.nnn.nnn.nnn:23896] AH01176: proxy_balancer_post_request for (balancer://screens_dev),
referer: https://servername.com:20443/
[Mon Jan 25 12:37:49.411899 2016] [ssl:info] [pid 9456:tid 2472] (OS 10060)A connection attempt
failed because the connected party did not properly respond after a period of time, or established
connection failed because connected host has failed to respond.  : [client nnn.nnn.nnn.nnn:23896]
AH01991: SSL input filter read failed.
[Mon Jan 25 12:37:49.411899 2016] [ssl:debug] [pid 9456:tid 2472] ssl_engine_io.c(1012): [client
nnn.nnn.nnn.nnn:23896] AH02001: Connection closed to child 246 with standard shutdown (server
servername.com:443)


Thanks,
Tom

Thomas S. Bumbernick
HPE Enterprise Services - Americas
Transformation Consulting
tom.bumbernick@hpe.com<mailto:tom.bumbernick@hpe.com>
Office  +1 404-648-7580
Mobile +1 717-659-0662
Hewlett Packard Enterprise

[hpe-logo-medium]

From: Eric Covener [mailto:covener@gmail.com]
Sent: Monday, January 25, 2016 1:53 PM
To: users@httpd.apache.org
Subject: Re: [users@httpd] Help Needed to add Connectiontimeout to ProxyPass


On Mon, Jan 25, 2016 at 1:51 PM, Bumbernick, Tom <tom.bumbernick@hpe.com<mailto:tom.bumbernick@hpe.com>>
wrote:
What’s interesting the app works for me (even with the message) but doesn’t work for the
client.  Something perhaps in their network?

​Good point, maybe need to see it in context with more verbose log level. It's not even
a proxy message.​



--
Eric Covener
covener@gmail.com<mailto:covener@gmail.com>
Mime
View raw message