httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel <dferra...@gmail.com>
Subject Re: [users@httpd] Multiple SSL virtual host PHP translation not working on only one via SSL
Date Thu, 03 Dec 2015 12:39:58 GMT
wrong path somewhere or invoking an incorrect script.

WSOD:
White Screen Of Death, one of PHP's specialties. It is produced when an
error has occurred in a PHP script and the error reporting goes either to
the error log or to nowhere. To solve it, look for the error reporting
settings in php.ini (or use ini_set()) of fpm pool.. Look or increase
logging at the errors from the php-fpm.

2015-12-03 1:24 GMT+01:00 Rose, John B <jbrose@utk.edu>:

> Apache 2.4
>
> I have 2 virtual hosts .conf files. Each has a port 80 and port 443
> section. The config files are identical in every way except for the
> DocumentRoot.
> Both use ProxyPassMatch for PHP-FPM
>
> In vhost1 I can go to http://…/ index.html and index.php successfully. If
> I use SSL I can go to http://  index.html successfully, but when
> accessing via SSL https:/ <https://…/index.php>/ index.php the screen is
> blank
>
> In vhost2 I can go to http:// index.html and index.php successfully, and
> when I go to https:// index.html and index.php come up successfully
>
> I did try changing so they did not have identical ports in ProxyPassMatch
>
> Any ideas why PHP translation would work via regular http but not be
> executed in the first virtual host via SSL connection?
>
> Thanks
>
>
>
>


-- 
*Daniel Ferradal*
IT Specialist

email         dferradal at gmail.com
linkedin     es.linkedin.com/in/danielferradal

Mime
View raw message