httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hilbert Set <hilbert...@gmail.com>
Subject Re: [users@httpd] Problem with LD_LIBRARY_PATH variable in httpd CentOS 7.1
Date Sun, 20 Dec 2015 17:37:24 GMT
Thanks for your reply.

>> What previous versions?
>> When *did* it work? With previous versions of
>> Apache httpd 2.4.* on CentOS 7.1, or on previous
>> versions of CentOS?

The last version in which it is surely working is CentOS 6.6, which has
httpd 2.2.15-39.
I cannot say after that.

On Sun, Dec 20, 2015 at 4:49 PM, Kurtis Rader <krader@skepticism.us> wrote:

> On Sun, Dec 20, 2015 at 5:09 AM, Hilbert Set <hilbertset@gmail.com> wrote:
>
>> Hello,
>> I am using the default httpd in CentOS 7.1, that is version 2.4.6-40.
>>
>> I need to set the LD_LIBRARY_PATH variable so that it is available to CGI
>> scripts as native system environment variable.
>> I do this by setting at the end of the file /etc/httpd/conf/httpd.conf:
>>
>> setenv LD_LIBRARY_PATH <path>
>>
>> I have always done this in previous versions and that has always worked
>> fine.
>> But is does not work in CentOS 7.1.
>>
>
> What previous versions? This entry from the CHANGES file might be relevant:
>
> Changes with Apache 2.4.2
>
>   *) SECURITY: CVE-2012-0883 (cve.mitre.org)
>      envvars: Fix insecure handling of LD_LIBRARY_PATH that could lead to
> the
>      current working directory to be searched for DSOs. [Stefan Fritsch]
>
>
>
> --
> Kurtis Rader
> Caretaker of the exceptional canines Junior and Hank
>

Mime
View raw message