httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Jagielski <...@jaguNET.com>
Subject Re: [users@httpd] Problem with LD_LIBRARY_PATH variable in httpd CentOS 7.1
Date Sun, 20 Dec 2015 16:58:36 GMT
When *did* it work? With previous versions of
Apache httpd 2.4.* on CentOS 7.1, or on previous
versions of CentOS?

Basically, I'm trying to track down whether the issue in in
CentOS 7.1 or in the Apache httpd code or maybe even in your
config itself.

> On Dec 20, 2015, at 8:09 AM, Hilbert Set <hilbertset@gmail.com> wrote:
> 
> Hello,
> I am using the default httpd in CentOS 7.1, that is version 2.4.6-40.
> 
> I need to set the LD_LIBRARY_PATH variable so that it is available to CGI scripts as
native system environment variable.
> I do this by setting at the end of the file /etc/httpd/conf/httpd.conf:
> 
> setenv LD_LIBRARY_PATH <path>
> 
> I have always done this in previous versions and that has always worked fine.
> But is does not work in CentOS 7.1.
> 
> I verified this by accessing the printenv.cgi script: the variable LD_LIBRARY_PATH is
not in its output.
> 
> The problem is specific of this variable: I can set any other variable I tested by using
the:
> 
> setenv <VARIABLE> <value>
> 
> code at the end of httpd.conf: it always works and - after restarting the httpd service
- printenv.cgi shows the variable and its value. It is just with the LD_LIBRARY_PATH that
it does not work.
> 
> I tried to understand if its value is overridden somewhere, but I could not find anything.
> Can someone please suggest some solution to this problem?
> Thanks.
>     Hilbert
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message