httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From KARANDEEP SINGH DHALIWAL <dhaliwal...@gmail.com>
Subject Re: [users@httpd] Fwd: Server Problem
Date Sun, 22 Nov 2015 18:23:39 GMT
I tried it and change permalinks but it still not working and having a same
problem.

In httpd.conf on line 154, LoadModule rewrite_module modules/mod_rewrite.so
is already enabled

On Sun, Nov 22, 2015 at 11:31 AM, Yehuda Katz <yehuda@ymkatz.net> wrote:

> You have AllowOverride set to none and you don't have mod_rewrite turned
> on anywhere else in your config, so this isn't a rewrite problem. The
> reason "http://localhost/KayD/index.php/2015/11/20/hello-world/" works is
> because Wordpress is processing the PATH_INFO of the URL.
>
> You should try disabling permalinks in Wordpress (
> https://codex.wordpress.org/Using_Permalinks - set to ugly) and see if
> your problem is resolved.
> I suspect that if you enable mod_rewrite (add RewriteEngine On and
> AllowOverride FileInfo in your config), and remove the index.php from your
> URL, then Wordpress will start working properly when you turn permalinks
> back on.
>
> I misread the error log you posted - it is actually saying that access is
> being denied to serve the .htaccess file (which is the correct behavior).
> This is in your httpd.conf around line 288 and it should remain there.
>
> - Y
>
> On Sun, Nov 22, 2015 at 10:34 AM, KARANDEEP SINGH DHALIWAL <
> dhaliwaljee@gmail.com> wrote:
>
>> httpd.conf = https://gist.github.com/dhaliwaljee/264eddd3958f01925d94
>> .htaccess = https://gist.github.com/dhaliwaljee/f263e27bede345a99639
>>
>> On Sun, Nov 22, 2015 at 9:27 AM, Yehuda Katz <yehuda@ymkatz.net> wrote:
>>
>>> The error log says the configuration that is denying access is in that
>>> .htaccess file. Can you post the contents of that file (putting it in a
>>> pastebin or gist and sending the link is a good way to avoid losing the
>>> formatting in an email).
>>>
>>> - Y
>>>
>>> Sent from a device with a very small keyboard and hyperactive
>>> autocorrect.
>>> On Nov 21, 2015 10:37 PM, "KARANDEEP SINGH DHALIWAL" <
>>> dhaliwaljee@gmail.com> wrote:
>>>
>>>>
>>>> ---------- Forwarded message ----------
>>>> From: KARANDEEP SINGH DHALIWAL <dhaliwaljee@gmail.com>
>>>> Date: Sat, Nov 21, 2015 at 8:17 PM
>>>> Subject: Server Problem
>>>> To: users@httpd.apache.org
>>>>
>>>>
>>>> I just installed [first time] WordPress 4.3.1, but I was facing the problem
with it so I downgraded and installed 4.2.5 and facing same problem.
>>>>
>>>> Problem: index.php is not loading, I clicked on link and also write in url
but still not working
>>>>
>>>> I uninstalled and then later I reinstalled and tried again but facing same
problem.
>>>>
>>>> After some google, I also tried other options as suggested on other websites.
>>>>
>>>> Remember, index.php on other directories are working fine.
>>>> Edit .htaccess
>>>> Change Theme
>>>> Restarted Apache and Mysql
>>>> but didn't work. Themes are also not showing Live Preview
>>>> But Dashboard is running
>>>>
>>>> Please Help
>>>>
>>>> My pc, I am not working on Xampp or Wampp. I have running Mysql and workbench
Apache as binary and then manually installed php
>>>> Thanks
>>>>
>>>> I also checked error.log it showing that error
>>>>
>>>> [Fri Nov 20 18:08:16.599079 2015] [authz_core:error] [pid 6188:tid 868] [client
::1:58552]
>>>> AH01630: client denied by server configuration: B:/server/Apache/Apache24/htdocs/KayD/.htaccess,
>>>> referer: http://localhost/kayd/
>>>>
>>>> Document Root B:\server\Apache\Apache24\htdocs\KayD
>>>>
>>>> I checked again http://localhost/KayD/index.php still has a problem but http://localhost/KayD/index.php/2015/11/20/hello-world/
is working
>>>>
>>>> What going on here?
>>>>
>>>>
>>>>
>>
>

Mime
View raw message