httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kurtis Rader <kra...@skepticism.us>
Subject Re: [users@httpd] How to switch between two Apache instalations?
Date Sun, 22 Nov 2015 16:53:55 GMT
On Sun, Nov 22, 2015 at 6:33 AM, Tylik <tylik.stec@gmail.com> wrote:

> Some time ago I installed Apache 2.2.29 with this manual:
> https://echo.co/blog/os-x-1010-yosemite-local-development-environment-apache-php-and-mysql-homebrew
> into this directory: */usr/local/Cellar/httpd22/2.2.29/bin/httpd*
> Yesterday I installed Apache 2.4.17 with this manual:
> https://www.youtube.com/watch?v=hV52Vs4E1xs into this directory:
> */usr/local/apache2/bin/httpd* Terminal command *which httpd* shows me
> this: *Server version: Apache/2.2.29 (Unix)* is there any way to switch
> to 2.4.17? (I'm on OS X 10.10.5)


The 2.2 version is installed where I would expect using Homebrew. The 2.4
version is not. Having said that the usual way to switch versions is with
the "brew link" command to create the appropriate symlinks in the
/usr/local/bin (and related) directories. However, you clearly have other
customizations in place since "which httpd" would not normally show the
output you reported. So it's possible your $PATH also contains atypical
entries that may cause httpd 2.2 to be found first even after you run "brew
link".


-- 
Kurtis Rader
Caretaker of the exceptional canines Junior and Hank

Mime
View raw message