httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amol Kulkarni <amolk1...@gmail.com>
Subject [users@httpd] 404 error - Restful webservice incorrectly considered as perl file
Date Wed, 18 Nov 2015 15:04:43 GMT
Hello,

I have a setup of Apache httpd + mod_jk + Tomcat 6.0 + Jersey on Centos 6.
The setup works correctly under normal circumstances.
The webservice urls r of format :

http://
<ip-addr>/application/domain/<domain-name>/user/<user-id>?properties=<propertyname>

However, if the <user-id> field, i.e the user id has a value ending with
.pl then I get a 404 error.

Eg.
http://192.168.0.17/application/domain/test.dom/user/amol.pl?properties=firstname

In httpd error_log, I get foll error :
File does not exist: amol.pl

I executed the webservice directly on tomcat by doing
http://192.168.0.17:8080/application/domain/test.dom/user/amol.pl?properties=firstname.
It worked correctly.

I'm not an expert in apache httpd configuration, so I tried some random
tricks with help from google, but could not get it working.
Foll things did not work :

   - Remove the "application/x-perl                pl" line from
   /etc/mime.types file.
   - Change ExecCGI to -ExecCGI.
   - Remove the perl.conf file from /etc/httpd/conf.d
   - Add explicit line JkMount /application/*.pl ajp13


Please help me in understanding and solving the problem.

Thanks in advance.
Amol.

Mime
View raw message