httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: [users@httpd] Cross-compiled apache 2.4.17/OpenSSL 1.0.2d for SPARC fails to start on mutex error
Date Mon, 16 Nov 2015 11:34:20 GMT
Am 16.11.2015 um 10:22 schrieb spggwp7q:
> Hi guys,
>
> I cross-compiled apache 2.4.17 with APR 1.5.2 and APR Util 1.5.4 along
> with OpenSSL 1.0.2d for 64-bit SPARC. I tried running it on one of my
> boxes and got the following error in the apache error log (the box was
> previously running 2.4.10):
>
> [Mon Nov 16 10:04:52.463583 2015] [core:emerg] [pid 17310:tid 1]
> (70023)This function has not been implemented on this platform: AH00023:
> Couldn't create the ssl-cache mutex
> AH00016: Configuration Failed
>
> I suppose there are no changes between 2.4.10 and 2.4.17 that require
> changes to the configuration, so I assume this is happening due to a
> compile-time issue.
>
> I was able to get over this error by explicitly setting:
>
> Mutex sem default
>
> However, now apache starts and then quickly dies.
>
> [Mon Nov 16 10:13:59.531153 2015] [mpm_worker:notice] [pid 27481:tid 1]
> AH00292: Apache/2.4.17 (Unix) OpenSSL/1.0.2d configured -- resuming
> normal operations
> [Mon Nov 16 10:13:59.532724 2015] [core:notice] [pid 27481:tid 1]
> AH00094: Command line: '/opt/SP/apps/ena_apache/current/bin/httpd -f
> /opt/SP/apps/apache/global/vfglfe/conf/httpd.conf'
> [Mon Nov 16 10:14:02.533892 2015] [core:notice] [pid 27481:tid 1]
> AH00051: child pid 27500 exit signal Bus error (10), possible coredump
> in /var/tmp
> [Mon Nov 16 10:14:02.534215 2015] [core:notice] [pid 27481:tid 1]
> AH00060: seg fault or similar nasty error detected in the parent process
>
> gdb is not installed on this box and I have no access to install
> it...but just looking into the core file I see:
>
> *** _THREAD_ERROR_DETECTION: lock usage error detected ***
>
> Looking for this error, I found this:
> https://issues.apache.org/jira/browse/STDCXX-1040, which seems to imply
> a possible issue with certain versions of Solaris.
>
> On my box, uname -a returns:
>
> SunOS now-ena-fe346 5.10 Generic_150400-20 sun4v sparc
> SUNW,SPARC-Enterprise-T5220
>
> I don't know if this is impacted by the issue with the standard C++ library
>
> Should I be using a specific version of the library for compilation?
>
> Thanks in advance for your support.

The Bus error could also be due to this bug in 2.4.17, that was fixed 
after the release:

svn.apache.org/r1712294

Maybe you can try that patch?

Regards,

Rainer

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message