httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yann Ylavic <ylavic....@gmail.com>
Subject Re: [users@httpd] Chunked transfer delay with httpd 2.4 on Windows.
Date Mon, 19 Oct 2015 23:14:16 GMT
On Tue, Oct 20, 2015 at 12:15 AM, Andy Wang <awang@ptc.com> wrote:
>
> On 10/19/2015 05:08 PM, Yann Ylavic wrote:
>>
>> On Mon, Oct 19, 2015 at 11:44 PM, Andy Wang <awang@ptc.com> wrote:
>>>
>>>
>>> Spdficially, note the 5 second delay between the first segment (No. 1854)
>>> and the second data segment (1856).
>>
>>
>> Does it correspond to the KeepAliveTimeout configured on the httpd side?
>> (Note that if you did not configure it, the default value is also 5
>> seconds).
>>
>> Can you reproduce with "KeepAlive off"?
>>
>
> Sorry, I forgot to mention that.  Yeah disabling KeepAlive makes the problem
> go away. Increasing the KeepAliveTimeout also increases the delay but only
> to a maximum of 20 seconds.
>
> I tried KeepAliveTimeout 30 and 60 and made a fresh connection and saw the
> second data packet arrive after a 20 second delay.

I forwarded the discussion on the dev@ mailing-list, since httpd is
delaying the write on the socket to fill in the pipe.
I think this should be limited to pipelined request, but would like to
ear others on this.

I will report here if you're not on dev@.

Regards,
Yann.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message