httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jack Swan <john.s...@oracle.com>
Subject Re: [users@httpd] apr version issue in Apache Installation on Mac OS X
Date Wed, 07 Oct 2015 13:29:04 GMT
Copy or move the apr and apr-util distributions into the httpd/srclib directory so you'll have


<path to your httpd distribution>/srclib/apr (without the version extension) 
<path to your httpd distribution>/srclib/apr-util (without the version extension) 

and try the --with-included-apr option to configure instead of the --with-apr and --with-apr-util
options. 


----- Original Message ----- 
From: doylejonathan58@yahoo.fr 
To: users@httpd.apache.org 
Sent: Wednesday, October 7, 2015 2:24:45 AM GMT -05:00 US/Canada Eastern 
Subject: [users@httpd] apr version issue in Apache Installation on Mac OS X 




This is my first in trying to install Apache HTTP server locally on my Yosemite Mac. 
I successfully installed APR version 1.5.2, APR-util version 1.5.4 and PCRE 2, but 
then I am stuck in the first step of the Apache installation. When I run ./configure 
in the httpd-2.4.16 directory, I get the error message : 

checking for APR version 1.3.0 or later... no 
configure: error: APR version 1.3.0 or later is required 

I do not understand this message, since (last time I checked) version 1.5.2 **is** later than
version 1.3.0. Here is the full command I typed : 



./configure --prefix=/Users/ewandelanoy/Documents/Installations/usr/local/ --with-apr=/Users/ewandelanoy/Documents/Installers/apr-1.5.2/apr-1-config
--with-apr-util=/Users/ewandelanoy/Documents/Installers/apr-util-1.5.4/apu-1-config --with-pcre=/Users/ewandelanoy/Documents/Installers/pcre2-10.10/pcre2-config



Any help appreciated. 

Mime
View raw message