httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From arnaud icard <arnaud.ic...@gmail.com>
Subject [users@httpd] "OpenSSL version is too old" while compiling http 2.4.16 on MacOS 10.11
Date Tue, 22 Sep 2015 20:53:12 GMT
Hi there,

I encounter an error with OpenSSL while compiling http 2.4.16 on El Capitan
10.11.1.

It is looking for OpenSSL version >= 0.9.8a:
    checking for OpenSSL... checking for user-provided OpenSSL base
directory... none
    checking for OpenSSL version >= 0.9.8a... FAILED
    configure: WARNING: OpenSSL version is too old


The default OpenSSL version is 0.9.8zg:
    $ openssl version
    OpenSSL 0.9.8zg 14 July 2015


And finally here is a part of my compilation line :
    ./configure --prefix=/usr/local/MyWebserver/httpd-2.4.16 \
    --enable-ssl \
    --with-few-things... \
    --disable-lots-of-things...


I don't want to install another openssl even with `brew`.


Is it an OpenSSL bug? An apache bug? Not a bug but a mistake of mine?
Could someone please help me on this one ?

Regards,
arnaud
-- 
--

Arnaud Icard

Mime
View raw message