httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aurélien Terrestris <aterrest...@gmail.com>
Subject Re: [users@httpd] "OpenSSL version is too old" while compiling http 2.4.16 on MacOS 10.11
Date Wed, 23 Sep 2015 07:11:46 GMT
Hello

in the configure file, you can remove the openssl version checking
starting at line 24787

  24787 #if OPENSSL_VERSION_NUMBER < 0x0090801f
  24788 #error "Unsupported OpenSSL version " OPENSSL_VERSION_TEXT
  24789 #endif



2015-09-22 22:53 GMT+02:00 arnaud icard <arnaud.icard@gmail.com>:
> Hi there,
>
> I encounter an error with OpenSSL while compiling http 2.4.16 on El Capitan
> 10.11.1.
>
> It is looking for OpenSSL version >= 0.9.8a:
>     checking for OpenSSL... checking for user-provided OpenSSL base
> directory... none
>     checking for OpenSSL version >= 0.9.8a... FAILED
>     configure: WARNING: OpenSSL version is too old
>
>
> The default OpenSSL version is 0.9.8zg:
>     $ openssl version
>     OpenSSL 0.9.8zg 14 July 2015
>
>
> And finally here is a part of my compilation line :
>     ./configure --prefix=/usr/local/MyWebserver/httpd-2.4.16 \
>     --enable-ssl \
>     --with-few-things... \
>     --disable-lots-of-things...
>
>
> I don't want to install another openssl even with `brew`.
>
>
> Is it an OpenSSL bug? An apache bug? Not a bug but a mistake of mine?
> Could someone please help me on this one ?
>
> Regards,
> arnaud
> --
> --
>
> Arnaud Icard

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message