httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rahul R <rahul.ra...@gmail.com>
Subject Re: [users@httpd] authn_core_module: apache 2.4 : Invalid command 'AuthLDAPBindDN'
Date Mon, 10 Aug 2015 06:46:01 GMT
Thanks for the suggestions. And now i am able to start apache 2.4 with ldap
settings. But the browser is not giving a prompt to enter the ldap
credentials, instead its opening up the page which I am trying to restrict.
No errors seen on the error.log. Any help would be much appreciated. Am I
missing some thing here? Below is the snippet from httpd.conf.

=============================

<AuthnProviderAlias ldap ldap-alias1>
AuthLDAPBindDN "myuser@global.ad.mycompany.com"
AuthLDAPBindPassword "asdfgh123"
AuthLDAPURL "ldap://
global.ad.mycompany.com:389/ou=NA,ou=PROD,dc=global,dc=ad,dc=mycompany,dc=com?sAMAccountName?sub?(objectClass=*)
"
</AuthnProviderAlias>

<AuthnProviderAlias ldap ldap-other-alias>
AuthLDAPBindDN "myuser@global.ad.mycompany.com"
AuthLDAPBindPassword "asdfgh123"
AuthLDAPURL "ldap://
global.ad.mycompany.com:389/ou=INTL,ou=PROD,dc=global,dc=ad,dc=mycompany,dc=com?sAMAccountName?sub?(objectClass=*)
"
</AuthnProviderAlias>

<AuthnProviderAlias ldap ldap-another-alias>
AuthLDAPBindDN "myuser@global.ad.mycompany.com"
AuthLDAPBindPassword "asdfgh123"
AuthLDAPURL "ldap://
global.ad.mycompany.com:389/ou=VLTY,ou=NA,ou=PROD,dc=global,dc=ad,dc=mycompany,dc=com?sAMAccountName?sub?(objectClass=*)
"
</AuthnProviderAlias>

Alias "/secure" "/home/apache2/htdocs"
<Directory /home/apache2>
#Order deny,allow
#Allow from all

AuthBasicProvider ldap-other-alias ldap-another-alias ldap-alias1

AuthType Basic
AuthName
Please_login_with_your_xxxxxx_as_username__and_windows_password_as_the_password
Require valid-user
</Directory>
====================================

On Fri, Aug 7, 2015 at 10:37 PM, Eric Covener <covener@gmail.com> wrote:

> On Fri, Aug 7, 2015 at 1:06 PM, Rahul R <rahul.raviz@gmail.com> wrote:
> > i hadn't added this module while configuring apache. I tried downloading
> > mod_authnz_ldap.c and compiling it with apxs. But its giving too many
> > errors. Is there a fix for this? A sample is below.
>
>
> Rebuild apache with the modules you now know you need.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>
>


-- 
Thanks,
Regards,
Rahul R

  .~.
  /V\
 // \\
/(   )\
 ^`~'^

Mob: 09008030921

Mime
View raw message