httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Macks, Aaron" <ama...@harvardbusiness.org>
Subject [users@httpd] SetenvIf warnings in 2.4
Date Fri, 10 Jul 2015 16:07:02 GMT
We’re migrating some configs from 2.2 to 2.4 and have run into an issue with using SetEnvIf
values in proxies.  Our config looks roughly like this:
    SetEnvIf Server_Addr 123.123.123.123 LEG=QA1 APPSERVER=appserver01
…

then we proxy using that APPSERVER value:
   ProxyPassInterpolateEnv On
   ProxyPass /app ajp://${ASAPPSERVER}:8009/app interpolate
…...

This all works as expected, EXCEPT on start and configtest we get the following warnings
[Fri Jul 10 16:05:10.022214 2015] [core:warn] [pid 15478] AH00111: Config variable ${APPSERVER}
is not defined

one for every time we use any of those variables.  We tried setting a default value with SetEnv,
then overwriting it with setenvif, but that didn’t fix anything.  What should we tweek in
the configs to conform to the 2.4 way and tamp down the useless warnings?

A

--
Aaron Macks
Systems Architect

Harvard Business Publishing
300 North Beacon St.    |   Watertown, MA 02472
(617) 783-7461                |   Fax: (617) 783-7467
www.harvardbusiness.org<http://www.harvardbusiness.org> |   Cell:(978) 317-3614


Mime
View raw message