httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ", ," <us.shadow...@gmail.com>
Subject Re: [users@httpd] Fwd: SSI directives not working on page used in ErrorDocument directive
Date Fri, 24 Jul 2015 19:04:35 GMT
So I assumed that even though my ErrorDocument was defined outside of
the directory where I have SSI parsing enabled it woudl be alright
since it references a file that is stored i that directory.

This does not seem to be the case though as when I added
AddOutputFilter INCLUDES .html before the ErrorDocument definition it
now functions.

Thanks for the suggestions.

On Thu, Jul 23, 2015 at 10:36 PM, Yehuda Katz <yehuda@ymkatz.net> wrote:
> What mechanism are you using to have SSI work on .html pages?
>
> I have no problem getting SSI to work when my page extension is .shtml:
> This is my very simple test which works perfectly:
>
> .htaccess:
>>
>> Options +Includes
>> ErrorDocument 404 /error.shtml
>
>
> error.shtml:
>>
>> Last modified: <!--#echo var="LAST_MODIFIED" -->
>
>
> Produces:
>>
>> Last modified: Thursday, 23-Jul-2015 23:34:55 Eastern Daylight Time
>
>
> Does it work for you if you use .shtml?
>
> - Y
>
> On Thu, Jul 23, 2015 at 4:06 PM, <eigenbrais1@gmail.com> wrote:
>>
>> Forgot to include my question,
>> Is there some additional step you have to take to get SSI to function
>> on an ErrorDocument page?
>> Thanks
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>> For additional commands, e-mail: users-help@httpd.apache.org
>>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message