httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ScuzzyEye <apache-l...@lists.scuzzyeye.com>
Subject Re: [users@httpd] Deny, Allow with Apache 2.4
Date Thu, 30 Jul 2015 07:01:59 GMT
On 7/30/2015 2:42 AM, Tobias Adolph wrote:
> Hi Chris,
>
> Am 30.07.2015 um 00:04 schrieb ScuzzyEye:
>> I'm having a difficult time figuring out how to convert an Apache 2.2
>> access rule to 2.4.
>>
>> What I'm doing in 2.2 is pretty simple:
>>
>> order deny,allow
>> deny from 192.168.1.0/24
>> deny from 192.168.2.0/24
>> allow from 192.168.1.12
>>
>> So denying some sub-nets, but allowing one IP in that range, and the
>> rest of the world.
>>
>
> Try this one:
>
> <RequireAny>
>          Require ip 192.168.1.12
>          <RequireAll>
>                  Require all granted
>                  Require not ip 192.168.1.0/24
>                  Require not ip 192.168.2.0/24
>          </RequireAll>
> </RequireAny>

As soon as I saw it, I knew that's what I was searching for. Tried it 
out, and it works perfectly.

Thanks so much!
-Chris

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message