httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jim Walls" <...@k6ccc.org>
Subject Re: [users@httpd] Help - 2.2 to 2.4 migration onto new server failing
Date Tue, 12 May 2015 20:11:01 GMT
Thank you for that suggestion.  I had not tried running it except as a 
service, so I tried it remotely a moment ago.  It did not do anything at 
all, and there was nothing in either the Windows logs or not Apache log.
  
 Since I have the server desktop in front of me, I will give the specific 
error messages.  When I try to start the Apache2.4 service I  get a popup 
box with the following:
  
 Windows could not start the Apache2.4 on Local Computer. For more 
information, review the System Event Log. If this is a non-Microsoft 
service, contact the service vendor, and refer to service-specific error 
code 1.
  
  
 When I look at the Windows System Event Log, I get the following two 
events:
  
 Event ID 7036  The apache2.4 service entered the stopped state.
  
 and
  
 Event 7024  The Apache2.4 service terminated with the following 
service-specific error:
 Incorrect function.
  
  
 There are no other events in any of the server logs.
  
  
  
  
  
  

----------------------------------------
 From: "Yehuda Katz" <yehuda@ymkatz.net>
Sent: Tuesday, May 12, 2015 11:29 AM
To: "users@httpd.apache.org" <users@httpd.apache.org>, "jim" 
<jim@k6ccc.org>
Subject: Re: [users@httpd] Help - 2.2 to 2.4 migration onto new server 
failing   
 Can you run httpd from the command line instead of as a service?  
 - Y

   On Tue, May 12, 2015 at 2:25 PM, Jim Walls <jim@k6ccc.org> wrote:   
Binaries downloaded from:
 http://www.apachelounge.com/download/
 Version 2.4 12 Windows 64 bit version (yes, I am running a 64 bit computer 
and OS.
  
 There is nothing at all in the Apache log except the original install log 
entry.  I assume because the service never starts.
  
 IIS is NOT running - one of the first things I checked after installing 
windows.  I will NEVER run IIS and make sure it's dead right away.  Checked 
again and it's did not resurrect itself from the dead.
  
 Jim
  
  

----------------------------------------
 From: "Yehuda Katz" <yehuda@ymkatz.net>
Sent: Tuesday, May 12, 2015 10:08 AM
To: "users@httpd.apache.org" <users@httpd.apache.org>, jim@k6ccc.org
Subject: Re: [users@httpd] Help - 2.2 to 2.4 migration onto new server 
failing     
  Which distribution are you using (a.k.a. where did you download from)?
  
Is there anything in the apache error log?    
   The first thing that comes to mind is make sure IIS is not running.
    
   - Y

     On Tue, May 12, 2015 at 12:55 PM, Jim Walls <jim@k6ccc.org> wrote:    
Help!  I have been running Apache 2.2 for quite a few years on an old 
Windows 2000 Server that recently died.  I have a new Windows 2012 R2 
server and trying to get Apache loaded on the new server.  It seemed like a 
good opportunity to upgrade from 2.2 to 2.4 in the process so that is what 
I installed on the new server.  I went through the config file and changed 
the few things that I caught that had to be changed, but the Apache service 
wont even start.  If I go into services and manually start it, I get an 
error message that says the service could not be started and gives a very 
generic error message that says to look in the Windows System event log for 
details.  When I look in the Windows System event log, all is says is that 
the service shut down due to an invalid function.  Finally renamed config 
files so that it had the default  "It works" configuration, and get the 
same problem.
  
 Anyone have an brilliant ideas?
   
 Jim 
   
   
   



Mime
View raw message