httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luc Andre <landre3...@gmail.com>
Subject Re: [users@httpd] Random latency in reentrant calls (Bug 57916)
Date Tue, 12 May 2015 10:03:57 GMT
php_sapi_name: apache2handler


Server MPM:     prefork

I tried

    StartServers          20
    MinSpareServers       20
    MaxSpareServers      20

And after restarting apache still have the issue but only after waiting
about a minute between 2 tries.

Then I did a "ps -ef | grep apache" and I discovered that I have only 11
apache processes running !

So it seems that MinSpareServers and StartServers  are ignored and the
problem is really a child spin up issue.

Regards,

Luc






On Tue, May 12, 2015 at 11:16 AM, Rainer Canavan <
rainer.canavan@sevenval.com> wrote:

>
>
> 2015-05-12 10:03 GMT+02:00 Luc Andre <landre3567@gmail.com>:
>
>> Thanks for your reply.
>>
>> We did a test on a powerful server with
>>
>>     StartServers          20
>>     MinSpareServers       5
>>     MaxSpareServers      20
>>
>> And we still have the issue...
>>
>
> To ensure that you don't hit the child spin up issue, you'll have to set
>  MinSpareServers to a value equal to or greater than the number of
> processes you need for your test, I'd recommend 20 in this case, just to be
> sure. Are you sure that you're using the prefork mpm, and therefore those
> settings are actually relevant? If you don't have a good reason to use
> prefork, you may get better performance with worker or event (but be sure
> to tune the associated settings, such as ThreadsPerChild appropriately)
>
> Additionally, you don't specify how your PHP is configured. If you're
> using PHP-FPM, you need to ensure that pm.start_servers and pm.min_spare_servers
> are large enough as well.
>
> rainer
>

Mime
View raw message