httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nathan Quirynen <nat...@pensionarchitects.be>
Subject [users@httpd] Subdomain vritual host proxy to Tomcat with ajp
Date Fri, 08 May 2015 07:14:10 GMT
I have a domain domain.com that points to a server. Now I have a 
subdomain sub.domain.com that points to another server that has Apache 
running and Tomcat. I want this subdomain to point to a application 
deployed on the Tomcat instance through ajp.

I have configured the following in httpd.conf:

|
<VirtualHost *:80>
     ServerName sub.domain.com
     ProxyRequests Off
     ProxyPreserveHost On
     <Proxy *>
     Order deny,allow
         Allow from all
     </Proxy>
     ProxyPass / ajp://localhost:8009/
     ProxyPassReverse / ajp://localhost:8009/
</VirtualHost>
|

and in Tomcats server.xml:

|<Connector port="8009" protocol="AJP/1.3" redirectPort="8443" />
|

But when I go to sub.domain.com the url changes to otherdomain.com and 
shows me a php website running in Apache and declared as following in 
httpd.conf:

|<VirtualHost *:80>
         DocumentRoot /var/www/html/otherdomain.com
         ServerName otherdomain.com
         ServerAlias www.otherdomain.com
</VirtualHost>
|

I only get it to work when I change the port in the sub.domain.com 
virtual host declaration to for example 8001. Then when I go to 
sub.domain.com:8001 it shows my tomcat application (ROOT.war) as expected.

So my question is: what could be going wrong that it doesn't work with 
the default port 80? I can't find any configuration that is causing 
this, but I'm probably missing something or is my virtual host 
configuration wrong?


Mime
View raw message