httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jack Connors <connorsj...@sbcglobal.net>
Subject [users@httpd] file write problem
Date Fri, 10 Apr 2015 19:50:34 GMT
Environment:
OpenSUSE 13.2 (x86_64)
Apache 2.4.10

Apache Error Log (/var/log/apache2/error_log):
[Fri Apr 10 12:30:44.021729 2015] [ssl:warn] [pid 1513] AH01873: Init: Session Cache is not
configured [hint: SSLSessionCache]
[Fri Apr 10 12:30:44.025051 2015] [mpm_prefork:notice] [pid 1513] AH00163: Apache/2.4.10 (Linux/SUSE)
OpenSSL/1.0.1k-fips configured -- resuming normal operations
[Fri Apr 10 12:30:44.025139 2015] [core:notice] [pid 1513] AH00094: Command line: '/usr/sbin/httpd2-prefork
-f /etc/apache2/httpd.conf -D SYSTEMD -D FOREGROUND'

Local config file (/etc/apache2/httpd.conf.local):
<Directory /tmp>
  AllowOverride None
  Require all granted
</Directory>


Excerpt from the CGI script:
my $testFile = '/tmp/test.txt';
my $m = "webPage starting\n";
open (FH, ">>", $testFile) or die "cannot open $testFile: $!\n"; 
print FH "$m";
close FH;


Problem:
I have a CGI script in perl.
The script writes to a file.
The file exists and has world read/write access.
This function worked with apache 2.2.17.
With 2.4, Nothing happens: no errors, no write to file.
I have tried the Directory directive shown in the local config file.
The local config is included in httpd.conf.

Any suggestions.


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message