httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Andre.Wen...@bmw.de>
Subject [users@httpd] Compile apache2.4 with mod_proxy_html/libxml2
Date Tue, 14 Apr 2015 14:34:06 GMT
Hello,

today I tried to compile the current apache 2.4.12 together with mod_proxy_html and xml2enc,
but I ran into some problem with libxml2, which is currently not installed on the system and
I'm not able to install the library in the system.

So what I did was to compile libxml2 as shared library with

./configure --prefix=/<apache-folder>/libxml2 --enable-shared=yes --with-python=no

After that I tried to build the apache with the following parameters:

./configure
...
  --enable-proxy-html \
  --enable-xml2enc \
  --with-libxml2=${apache_prefix}/libxml2

I also tried the following:

./configure
...
  --enable-proxy-html \
  --enable-xml2enc \
  --with-libxml2 \
  --with-libxml2-include=${apache_prefix}/libxml2/include \
  --with-libxml2-lib=${apache_prefix}/libxml2/lib

But every time the following error comes up,

...
checking whether to enable mod_deflate... shared
checking whether to enable mod_xml2enc... checking dependencies
checking for libxml2... checking for libxml2... no
checking whether to enable mod_xml2enc... configure: error: mod_xml2enc has been requested
but can not be built due to prerequisite failures
...

Does somebody have any idea, what is the problem or which configuration I need to set, so
that I can build the apache with mod_proxy_html support. But I don't need to install libxml2
on the system? Is there any additional compiler setting needed?

Thanky & Best regards,
André

Mime
View raw message