httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rainer Jung <rainer.j...@kippdata.de>
Subject Re: [users@httpd] How to enable TLSV1.1 or above on Apache
Date Fri, 27 Mar 2015 14:28:49 GMT
Am 27.03.2015 um 14:40 schrieb Cathy Fauntleroy:
> I am on a Windows 2008 R2 server with Apache 2.2.25/OpenSSL 0.9.8 installed.  I am attempting
to upgrade OpenSSL to 1.0.1 so that TLS 1.1 and 1.2 will be enabled.  I am having problems
installing 1.0.1 because of what appears to be a platform conflict.  My installation halts
because a file in what is definitely a Unix/Linux path is not found.  I am on a Windows platform
and downloaded a file for windows.  Any help would be greatly appreciated.  Am I missing something
or have I stumbled upon a mis-categorized download?  I've tried several sites.

On the Windows platform many use the binary Apache httpd downloads from 
ApacheLounge:

http://www.apachelounge.com/download/

Regards,

Rainer

> -----Original Message-----
> From: Rainer Jung [mailto:rainer.jung@kippdata.de]
> Sent: Friday, March 27, 2015 5:53 AM
> To: users@httpd.apache.org
> Subject: Re: [users@httpd] How to enable TLSV1.1 or above on Apache
>
> Am 27.03.2015 um 06:22 schrieb Sailaja Gadireddy:
>> Hello Team,
>>
>> I have upgraded my apache to Apache V2.4.3. and OpenSSL version is
>> 0.9.8g
>>
>> When I have modified httpd conf with SSLProtocol TLSV1.1, It says
>> Illegal protocol.
>>
>> Do I need to install latest openssl version? If so please suggest the
>> version.
>>
>> Please suggest me the way to enable TLSV1.1 on Apache.
>
> You need OpenSSL 1.0.1 as a minimum for TLS 1.1 (and 1.2) support.
>
> Regards,
>
> Rainer


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message