httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rose, John B" <jbr...@utk.edu>
Subject Re: [users@httpd] Apache and PHP-FPM error
Date Fri, 13 Feb 2015 21:10:33 GMT
We will check it. 

We use collectd to view full cpu usage. The user cpu usage is much lower
than prefork but the system cpu usage has increased significantly with
PHP-FPM. Pushing the total cpu load to ~90% frequently.

We have gone with the default settings for PHP-FPM.

This particular box has 16 cores and 48 GB RAM.

We are also using Event MPM.

We are not as familiar with how the threaded MPMs work as with prefork. So
we have just left the MaxRequestWorkers 400, etc. for the time being.


On 2/13/15 3:55 PM, "Tom Evans" <tevans.uk@googlemail.com> wrote:

>On Mon, Feb 9, 2015 at 8:20 PM, Rose, John B <jbrose@utk.edu> wrote:
>> Bummer
>>
>> Since we want to stick with what is available via "yum" for Red Hat 7
>>
>> Thanks for the info
>>
>
>I doubt the lack of UDS, and having to use FCGI over TCP/IP is what is
>causing your load spikes compared to running with mod_php.
>
>More likely you need to tune the PHP-FPM side to start (+limit) the
>appropriate number of processes appropriate for your workload and
>available resources. A common cause of poor req/s is trying to service
>too many requests simultaneously, ie starting 100 FCGI workers on a 2
>CPU server.
>
>Cheers
>
>Tom
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>For additional commands, e-mail: users-help@httpd.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message