httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel <dferra...@gmail.com>
Subject Re: [users@httpd] apache 2.4 Require IP
Date Wed, 04 Feb 2015 21:41:50 GMT
you forgot to load the module proper

El Wed Feb 04 2015 at 7:22:18 PM, Tim Dunphy (<bluethundr@gmail.com>)
escribió:

> Hey all,
>
>  I need to allow access to a list of IPs to the server-status of some
> hosts. I tried out the new syntax I used according to this document:
>
>  http://httpd.apache.org/docs/current/mod/mod_authz_host.html
>
> So I have my server-status block set like this:
>
> <Location /server-status>
>     SetHandler server-status
>     Require ip 10.10.10.1 10.10.10.2/24 10.10.3.0/24
> </Location>
>
>
> And when I go to check syntax on what I've done I get this error:
>
> [root@224432-27 apache2]# apachectl -t
> AH00526: Syntax error on line 461 of /opt/apache2/conf/httpd.conf:
> Unknown Authz provider: ip
>
> Can you please clue me in on the correct syntax I would use for apache
> 2.4.10?
>
> Thank you,
> Tim
>
> --
> GPG me!!
>
> gpg --keyserver pool.sks-keyservers.net --recv-keys F186197B
>
>

Mime
View raw message