httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henrik Hudson <li...@rhavenn.net>
Subject Re: [users@httpd] apache not started due to openssl upgrade
Date Tue, 13 Jan 2015 17:29:40 GMT
On Tue, 13 Jan 2015, Kannan Narayanasamy -X (kannanar - HCL TECHNOLOGIES LIMITED at Cisco)
wrote:

> Hi,
> 
> We are using Apache 2.2.17. due to some vulnerability issue on openssl was upgraded to
0.9.8.zc version. After that apache process is not getting started and throws below error.
> 
> Error:
> ---------
> The Apache service named  reported the following error: >>> Apache.exe: Syntax
error on line 1072 of /Apache/conf/httpd.conf: Cannot load /modules/mod_ssl.so into server:
The operating system cannot run The Apache service named.     .
> 
> We need to upgrade mod_ssl as well? The same upgrade scenario is working fine in Linux,
facing issue with Windows. Any pointer? Thanks in advance.
> 
> Thanks,
> Kannan Narayanasamy.

mod_ssl always has to be paired with the same version as the OpenSSL version.
So, yes, you will need to upgrade / re-compile your Apache / mod_ssl
package.
> 

-- 
Henrik Hudson
lists@rhavenn.net
-----------------------------------------
"God, root, what is difference?" Pitr; UF 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message