httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rian Kruger <riankru...@gmail.com>
Subject [users@httpd] mod proxy_wstunnel invalid utf8 during upgrade
Date Mon, 29 Dec 2014 18:50:17 GMT
Hi

I am experiencing an intermittent problem when connecting the jetty
web-socket client to the server. The good people at Jetty assure me it is
not a problem with Jetty.

On the server side I have apache with mod proxy_wstunnel proxying to tomcat
7.

When I take apache out of the picture and connect the client directly to
tomcat, the error seems to disappear. Also the error does not seem to
happen when I run the client on linux, the problem only seems to occur on
windows 7.

I've noticed that apache is returning a 500 html page at some stage,
however, even if I set the loglevel to debug, I don't get any useful
information on how to resolve the error.

If anyone could help me figure out how to resolve this it would be much
appreciated. Hours of googling have helped. You are my last hope...

The software version are:

apache Server version: Apache/2.4.7 (Ubuntu), Server built:   Jul 22 2014
14:36:38
tomcat Apache Tomcat/7.0.52 (Ubuntu) 1.8.0_25-b17 Oracle Corporation Linux
   3.13.0-32-generic
Jetty client: 9.2.6.v20141205

I've attached the logs.

There is also a ticket on stackoverflow, should you wish to get points
there:

http://stackoverflow.com/questions/27638895/jetty-websocket-client-not-valid-utf8

Any help would be much appreciated.

Thanks in advance.

Rian

Mime
View raw message