httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From H Plato <hpl...@gmail.com>
Subject Re: [users@httpd] Proxy problems when using subdirectory
Date Thu, 20 Nov 2014 03:00:20 GMT
Thanks for the suggestion, but still no success. Again /a/ works, but any link in the proxied
site that begins with “/“ does not.

Nothing interesting in the logs, either: the error log has a few of these entries:

[Wed Nov 19 19:51:58.309834 2014] [include:warn] [pid 22620] [client 192.168.3.184:63724]
AH01374: mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed:
/a/site/menu.shtml, referer: http://www/a/site/index.shtml

From the access log, I can see the problematic URLs and the resulting 404 errors:

192.168.3.184 - - [19/Nov/2014:19:51:55 -0700] "GET /a/site/top.shtml HTTP/1.1" 200 485
192.168.3.184 - - [19/Nov/2014:19:51:55 -0700] "GET /default.css HTTP/1.1" 404 277
192.168.3.184 - - [19/Nov/2014:19:51:55 -0700] "GET /site/images/lo.gif HTTP/1.1" 404 294
192.168.3.184 - - [19/Nov/2014:19:51:55 -0700] "GET /site/images/pa.gif HTTP/1.1" 404 289
192.168.3.184 - - [19/Nov/2014:19:51:55 -0700] "GET /a/site/menu.shtml HTTP/1.1" 200 1414
192.168.3.184 - - [19/Nov/2014:19:51:55 -0700] "GET /default.css HTTP/1.1" 404 277
192.168.3.184 - - [19/Nov/2014:19:51:55 -0700] "GET /default.css HTTP/1.1" 404 277
192.168.3.184 - - [19/Nov/2014:19:51:58 -0700] "GET /a/site/index.shtml HTTP/1.1" 200 374
192.168.3.184 - - [19/Nov/2014:19:51:58 -0700] "GET /default.css HTTP/1.1" 404 277

> On Nov 19, 2014, at 2:37 PM, Igor Cicimov <icicimov@gmail.com> wrote:
> 
> 
> On 20/11/2014 1:04 AM, "H Plato" <hplato@gmail.com <mailto:hplato@gmail.com>>
wrote:
> >
> > Thanks Eric,
> >
> > I've tried so many combinations of this with no success, both in and out of a location
block. This should work according to the docs, but it doesn't (i'm writing this from memory
so might have syntax wrong):
> >
> > <location /a/>
> >   ProxyHTMLURLMap / /a/
> >   ProxyHTMLURLMap /bin/  /a/bin/
> > </location>
> >
> > Sent from my mobile device.
> >
> Try this in the vhost
> 
> ProxyHTMLEnable On
> ProxyPass /a/ http://192.168.0.51:80/ <http://192.168.0.51/>
> ProxyPassReverse /a/ http://192.168.0.51:80/ <http://192.168.0.51/>
> ProxyHTMLURLMap http://192.168.0.51:80/ <http://192.168.0.51/> /a/


Mime
View raw message