httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Edgar Pettijohn <ed...@pettijohn.no-ip.biz>
Subject Re: [users@httpd] Error when restarting server as root
Date Thu, 06 Nov 2014 13:02:51 GMT
Have you tried these:

# apachectl graceful
# apachectl configtest

On 11/05/2014 10:40 PM, Steve Matzura wrote:
> I'm running version 2.2 on a Debian 4 system (OK, don't laugh please).
> It's been running swell for years. And before anyone says the answer
> to life, the universe and everything is to upgrade to 2.4, that's
> already been done on a test bed, and yes, I'm having the same problem
> over there. It's this: When entering the command:
>
> ./usr/sbin/apache2 -k restart
>
> I receive the following response:
>
> apache2: bad user name ${APACHE_RUN_USER}
>
> If I grep for APACHE_USER_NAME in apache.conf it comes up defined as
> www-data in an export statement. Same for the run group.
>
> The server runs fine when the system is rebooted. The reason I want to
> restart it is because I've made some changes to httpd.conf (added some
> virtual hosts) and want to have them incorporated into the server's
> normal operation. And just in case you might be thinking there's a
> problem with my httpd.conf, there isn't. It passes syntax-checking,
> and if I replace mine with the empty one that was there originally,
> same error.
>
> I think I've covered all the bases. Any thoughts greatly appreciated.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
> For additional commands, e-mail: users-help@httpd.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message