httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher Stanley <ch...@stanleynetworks.net>
Subject Re: Re: [users@httpd] Trouble upgrading to 2.2.29 from 2.2.8 - mod_deflate error
Date Mon, 03 Nov 2014 17:05:53 GMT
Thanks so much Yann, Your solution worked!




I try to avoid using LD_LIBRARY if I have to as that's hackish :P 


It appears that when I installed APR myself for mod_security there was a conflict with the
old APR versions. Now I have two versions of APR installed. I will try to update the default
installed ones.


Thanks again! (with-included-apr was the answer)

---- On Sat, 01 Nov 2014 17:47:44 -0400 Yann Ylavic &lt;ylavic.dev@gmail.com&gt; wrote
---- 

Hello Christopher, 
 
there seem to be an old APR library (&lt; v1.3.0) installed on your 
system (/usr/local/apache2/include?). 
 
What ./configure options did you use? 
You probably need to compile (and run) with the APR embedded in the 
httpd-2.2.29 archive using: ./configure --with-included-apr .... 
At runtime, it might also be necessary to link with this newly 
installed APR using something like LD_LIBRARY. 
 
Regards, 
Yann. 
 
On Thu, Oct 30, 2014 at 8:10 PM, Christopher Stanley 
&lt;chris@stanleynetworks.net&gt; wrote: 
&gt; Hey guys! 
&gt; 
&gt; I am having trouble upgrading from Apache 2.2.8 -&gt; 2.2.29 with the following

&gt; error occurring after running 'make' 
&gt; 
&gt; /usr/local/apache2/build/libtool --silent --mode=compile gcc -g -O2 -pthread 
&gt; -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -D_LARGEFILE64_SOURCE 
&gt; -I/opt/vignette/software/apache/srclib/pcre -I. 
&gt; -I/opt/vignette/software/apache/os/unix 
&gt; -I/opt/vignette/software/apache/server/mpm/prefork 
&gt; -I/opt/vignette/software/apache/modules/http 
&gt; -I/opt/vignette/software/apache/modules/filters 
&gt; -I/opt/vignette/software/apache/modules/proxy 
&gt; -I/opt/vignette/software/apache/include 
&gt; -I/opt/vignette/software/apache/modules/generators 
&gt; -I/opt/vignette/software/apache/modules/mappers 
&gt; -I/opt/vignette/software/apache/modules/database 
&gt; -I/usr/local/apache2/include 
&gt; -I/opt/vignette/software/apache/modules/proxy/../generators 
&gt; -I/usr/kerberos/include -I/opt/vignette/software/apache/modules/ssl 
&gt; -I/opt/vignette/software/apache/modules/dav/main -prefer-non-pic -static -c 
&gt; mod_deflate.c &amp;&amp; touch mod_deflate.lo 
&gt; mod_deflate.c: In function `deflate_out_filter': 
&gt; mod_deflate.c:790: error: `APR_INT32_MAX' undeclared (first use in this 
&gt; function) 
&gt; mod_deflate.c:790: error: (Each undeclared identifier is reported only once 
&gt; mod_deflate.c:790: error: for each function it appears in.) 
&gt; mod_deflate.c: In function `deflate_in_filter': 
&gt; mod_deflate.c:1165: error: `APR_INT32_MAX' undeclared (first use in this 
&gt; function) 
&gt; mod_deflate.c: In function `inflate_out_filter': 
&gt; mod_deflate.c:1550: error: `APR_INT32_MAX' undeclared (first use in this 
&gt; function) 
&gt; make[3]: *** [mod_deflate.lo] Error 1 
&gt; make[3]: Leaving directory 
&gt; `/opt/vignette/software/httpd-2.2.29/modules/filters' 
&gt; make[2]: *** [all-recursive] Error 1 
&gt; make[2]: Leaving directory 
&gt; `/opt/vignette/software/httpd-2.2.29/modules/filters' 
&gt; make[1]: *** [all-recursive] Error 1 
&gt; make[1]: Leaving directory `/opt/vignette/software/httpd-2.2.29/modules' 
&gt; make: *** [all-recursive] Error 1 
&gt; 
&gt; I am running RHEL4 (I know it's bad) 
&gt; 
&gt; Any help would be much appreciated! 
&gt; 
&gt; Thanks! 
 
--------------------------------------------------------------------- 
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org 
For additional commands, e-mail: users-help@httpd.apache.org 
 






Mime
View raw message