httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "bae.hk" <eyeb...@gmail.com>
Subject [users@httpd] Re: my dumpio log was missing
Date Mon, 29 Sep 2014 08:47:28 GMT
Hi, I am Bae (from Japan).

(apache Version: 2.0.64)

I installed the mod_dumpio, and getting request and reponse information
from error.log.
But in case of "GIF"(image) file, output chars are missing.

(Example) test.gif
①[binary] ...d8 ff e0 00 10 4a 46 49 46 00 01 01 01 00 48 00...
②[dumpio_out] ...4a 46 49 46...
※Therefore, binary source data("d8 ff e0 00 10","00 01 01 01 00 48 00") are
missing.

It seems that this occur in all image file (not only gif).

Is there any solution of getting all binary bytes of the image file?
(apache or mod_dumpio's setting?)

Thank you very much for your help.


2014-07-24 17:38 GMT+09:00 bae.hk <eyebird@gmail.com>:

> Hi, I am Bae (from Japan).
>
> (apache Version: 2.0.64)
>
> I installed the mod_dumpio, and getting request and reponse information in
> error.log.
> But if log(one line) becomes long, the log of the one line'end is missing.
>
> (Example) error.log
> ①dumpio_out (data-HEAP): 111222333444555666 (→ "777" is missing)
> ②dumpio_out (data-HEAP): 888999
> ※ Therefore, put together log above ①②, cannot get correct response("777"
> is missing).
>
> It seems that this occur if one line becomes long, but cannot tell the
> point that the missing begins in(not a particular character, not a specific
> location).
>
> Is there any solution of keeping a log from being missing?
> (apache or mod_dumpio's setting?)
>
> Thank you very much for your help.
>
>


-- 

      )/

      Y\_/

       /~\

Mime
View raw message