httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Remco Poelstra <re...@beryllium.net>
Subject Re: [users@httpd] Mailman CGI scripts served instead of executed
Date Tue, 01 Jul 2014 11:04:11 GMT

Op 1 jul. 2014, om 11:20 heeft Jens-U. Mozdzen <jmozdzen@nde.ag> het volgende geschreven:

> Hi Remco,
> 
> Zitat von Remco Poelstra <remco@beryllium.net>:
> 
>> Adding an extension to the binaries had the same effect as adding the entry:
>> <Directory /var/www/w-lists>
>> 	SetHandler fcgid-script
>> </Directory>
>> 
>> I now get an Internal Server Error page and when I check the error.log I see the
output of the script, which is a basic html page. It’s followed by:
>> (104)Connection reset by peer: [client 127.0.0.1:56565] mod_fcgid: error reading
data from FastCGI server
>> [client 127.0.0.1:56565] End of script output before headers: listinfo
> 
> are those binaries actually FastCGI binaries, or just CGI programs? FastCGI programs
would run in a loop, handling one request after the other, by serving a specific API. Plani
CGI programs are invoked once per HTTP request and output the complete response.
> 
>> The php wrapper keeps functioning like it should.
>> Is this a step forward or a step backward?
> 
> Sideways, I'd say. You now get the programs called, but probably via the wrong interface
;)

Yes, that fixes it all. Enabled the cgi module and set the handler to normal cgi and it’s
all up and running now.

Thanks!

Remco



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
For additional commands, e-mail: users-help@httpd.apache.org


Mime
View raw message