httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ritesh Prajapati <ritesh.prajap...@slscorp.com>
Subject Re: [users@httpd] HTTP request failed after listening on multiple ports or enabling SSL Module on my Linux Board
Date Thu, 17 Jul 2014 13:57:05 GMT
Hi,

Thanks for providing reply.

Yes. It works fine without any issue on my custom Linux Board with 
single listen port but failed to execute on multiple listen ports.

I have started my httpd process with "*-DNO_DETACH -DONE_PROCESS*" 
options and debug that process using strace on my Linux Board with 
single and multiple listen port requests.

I have found from strace output of each request that following two 
system calls are not executed in multiple listen port request compare to 
single listen port request which is used to create that fd as non blocking.

     fcntl64(9, F_GETFL)                     = 0x2 (flags O_RDWR)
     fcntl64(9, F_SETFL, O_RDWR|O_NONBLOCK)  = 0

so that *read()* system call goes into hang state after sending HTTP 
request in multiple listen port on my custom Linux board.

Please find attached text files which contains output of strace command 
of single and multiple listen ports request of my custom Linux board.

Regards,
Ritesh Prajapati,
System Level Solutions (India) Pvt.Ltd.

On Thursday 17 July 2014 04:28 PM, Jeff Trawick wrote:
> On Wed, Jul 16, 2014 at 7:17 AM, Ritesh Prajapati 
> <ritesh.prajapati@slscorp.com <mailto:ritesh.prajapati@slscorp.com>> 
> wrote:
>
>     Hi All,
>
>     I have one Custom Linux board on which I want to run apache web
>     server (httpd) to test HTML and other web based pages.
>
>     I have configured, cross compiled and installed httpd (2.2.24,
>     2.4.1, 2.4.4 and 2.4.9 packages) on my Linux PC (Ubuntu 12.04 LTS)
>     as well as
>     on my own custom Linux board. Then I have added support of SSL
>     Module (mod_ssl) to test HTTP as well as HTTPS request.
>
>     Both HTTP and HTTPS request works fine without any issue on my
>     Linux PC (Ubuntu 12.04 LTS). But when I tried to execute same HTTP
>     request
>     on my Linux Board using httpd (2.4.4 and 2.4.9 with SSL Module
>     Enabled) at that time browser page goes into loading state and can
>     not be came out from that situation.
>     Also I have seen that HTTPS request works fine at that time.
>
>
> Does it work on your Linux board with just one listening socket 
> enabled?  ("Listen 0.0.0.0:80 <http://0.0.0.0:80>")
>
>
>     I have also did some debugging task through wire-shark tool and
>     found that connection is established successfully after sending
>     request through HTTP
>     but can not get response of that request. I have also found that
>     response of that HTTP request received on wire-shark after closing
>     that HTTP
>     requested page from browser.
>
>     Also, I can run HTTP and HTTPS requests successfully using httpd
>     (2.2.24 and 2.2.27 with SSL Module enabled) on my Linux Board as
>     well but failed to execute same request
>     using httpd (2.4.X with SSL Module enabled) package.
>
>     I have also changed some configurations by creating different
>     virtual host for HTTP (Port 80) and HTTPS (Port 443) but still
>     failed to
>     execute that HTTP request.
>
>     I have also tried to listen on different ports like (Listen 80 and
>     Listen 8000) without SSL module (using httpd 2.4.4. and 2.4.9 ) at
>     that
>     time HTTP request goes into loading state.
>
>     Does anyone has idea about this issue or help me to solve this
>     type of issue?
>
>
> It might be a basic problem with the cross-compile -- syscalls used 
> inappropriately due to wrong decisions made at configure time.
>
> Do you have strace or similar available on the Linux board?  Configure 
> it with the prefork MPM, start it with -DNO_DETACH -DONE_PROCESS 
> arguments, strace -f against it, then send a request.
>
>
>
>     -- 
>     Regards,
>     Ritesh Prajapati,
>     System Level Solutions (India) Pvt.Ltd.
>
>
>
>     ---------------------------------------------------------------------
>     To unsubscribe, e-mail: users-unsubscribe@httpd.apache.org
>     <mailto:users-unsubscribe@httpd.apache.org>
>     For additional commands, e-mail: users-help@httpd.apache.org
>     <mailto:users-help@httpd.apache.org>
>
>
>
>
> -- 
> Born in Roswell... married an alien...
> http://emptyhammock.com/
> http://edjective.org/
>


Mime
View raw message