httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Felt <mamf...@gmail.com>
Subject [users@httpd] Problem with Content-Type recognition
Date Sat, 21 Jun 2014 14:45:10 GMT
I have tried, in a vhost area, to set the DefaultType to
application/octet-stream, and I have tried to add a Type for .I (capital i)
endings. However, httpd-2.2.27 seems to be preferring the .php. in the
filename rather than the .I at the end of the file. When I link the file to
that it has the name *.php5.* then the ContentType: is as expected.

Wrong:
# wget -q -d http://dl.aixtools.net/php/aixtools.php.5.2.17.0.I
DEBUG output created by Wget 1.13.4 on aix5.3.0.0.

Caching dl.aixtools.net => 86.85.86.223
Created socket 3.
Releasing 0x200336b8 (new refcount 1).

---request begin---
GET /php/aixtools.php.5.2.17.0.I HTTP/1.1
User-Agent: Wget/1.13.4 (aix5.3.0.0)
Accept: */*
Host: dl.aixtools.net
Connection: Keep-Alive

---request end---

---response begin---
HTTP/1.1 200 OK
Date: Sat, 21 Jun 2014 14:37:40 GMT
Server: Apache/2.2.27 (Unix) PHP/5.2.17 mod_ssl/2.2.27 OpenSSL/1.0.1e DAV/2
X-Powered-By: PHP/5.2.17
Content-Length: 316
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Content-Type: text/html
Content-Encoding: x-binary

---response end---
Registered socket 3 for persistent reuse.

Correct:
# wget -q -d http://dl.aixtools.net/php/aixtools.php5.5.2.17.0.I
DEBUG output created by Wget 1.13.4 on aix5.3.0.0.

Caching dl.aixtools.net => 86.85.86.223
Created socket 3.
Releasing 0x200336c8 (new refcount 1).

---request begin---
GET /php/aixtools.php5.5.2.17.0.I HTTP/1.1
User-Agent: Wget/1.13.4 (aix5.3.0.0)
Accept: */*
Host: dl.aixtools.net
Connection: Keep-Alive

---request end---

---response begin---
HTTP/1.1 200 OK
Date: Sat, 21 Jun 2014 14:45:25 GMT
Server: Apache/2.2.27 (Unix) PHP/5.2.17 mod_ssl/2.2.27 OpenSSL/1.0.1e DAV/2
Last-Modified: Fri, 20 Jun 2014 19:36:29 GMT
ETag: "69c002e-22f2200-4fc499c200940"
Accept-Ranges: bytes
Content-Length: 36643328
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Content-Type: application/octet-stream
Content-Encoding: x-binary

---response end---
Registered socket 3 for persistent reuse.

Question: what do I need to do to get httpd to recognize the .I endings
and/or ignore .php when in the middle of a filename?

Thanks!

Mime
View raw message