httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Humberto Castro <humbertoe.cast...@gmail.com>
Subject [users@httpd] ¿Cómo se soluciona "500 Internal Server Error" ?
Date Fri, 18 Apr 2014 17:29:17 GMT
**************************************************
¿Cómo se soluciona '500 Internal Server Error' ?
**************************************************

Hola. Estoy configurando Acceso Restringido a un directrio dentro de mi
sitio web, usando el archivo '.htaccess' el cual hace referencia al archivo
en donde se encuentra la lista de usuarios, denominado '.htpasswd'; pero
habiendo ya cargado los dos archivos (a la misma carpeta), cuando intento
acceder mediante el explorador de internet a la carpeta protegida, la
primera vez se muestra la ventana emergente pidiendo el Nombre_de_Usuario y
la Contraseña, pero una vez entro los datos se muestra el siguiente mensaje:

--------------------------------------------------
Internal Server Error

The server encountered an internal error or misconfiguration and was unable
to complete your request.

Please contact the server administrator, support@dominio.com and inform
them of the time the error occurred, and anything you might have done that
may have caused the error.

More information about this error may be available in the server error log.
--------------------------------------------------

Y las siguientes veces que vuelvo a intentar entrar, ya ni siquiera me pide
el Nombre_de_Usuario y Contraseña, sino que de una vez se muestra el mismo
mensaje de error anterior. ¿Qué podría estar haciendo mal en el
procedimiento ? Gracias y ojalá me puedan ayudar.

Inicialmente intenté la protección colocando el archivo .htpassswd en la
raiz, y de acuerdo a esto colocando la primera linea de .htaccess así:
'AuthUserFile /.htpasswd'. En este punto del tiempo el inconveniente
presentado fue exactamente el mismo (la primera vez el sistema me pidió el
Nombre_de_Usuario y Contraseña, y luego me presentó el mensaje de error;
las siguientes veces ni siquiera me pidió los datos del usuario y de una
vez me presentó el error). Por eso opté por pasar el '.htpasswd' al mismo
directorio protegido para detectar bien cuál era el error de mi parte.

He probado también dejando el archivo '.htaccess' completamente en blanco
y, de esta forma no se me genera ningún mensaje de error, claro que
obviamente no me pide datos para validar Nombre_de_Usuario.

Inicialmente esperaba que la contraseña original para el usuario dentro del
archivo '.htpasswd' fuera encriptada la función crypt() de PHP, pero esto
no se dio.

--------------------------------------------------
EL contenido de mi archivo '.htaccess' es:
AuthUserFile /ruta/.htpasswd
AuthName 'Por favor, introduzca usuario y contraseña'
AuthType Basic
Require valid-user

El contenido del archivo '.htpasswd' es:
uprueba:cumGzwtU82Vts
--------------------------------------------------

He detectado que al quitar la linea 'Require valid-user' no se genera el
error - pero obviamente deja entrar al directorio sin validar el usuario.
Inclusive he intentado cambiando esta linea por 'Require user uprueba',
pero de esta forma se genera exactamente el mismo mensaje de error.

También he cambiado los permisos a ambos archivos a '755', inclusive a
'777', pero se sigue generando el error.


--
HUMBERTO

Mime
View raw message