httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <ayaskanta.praha...@wipro.com>
Subject [users@httpd] problem while loading module mod_proxy_html.so into httpd.conf
Date Mon, 24 Mar 2014 14:20:07 GMT
Hi,

Can you help me on the below problem -



I am running apache 2.4.9 in Linux 64 system successfully and trying to install proxy_html
package now. I downloaded and installed the the rpm files for libxml2, proxy_html and xml12enc
packages. After that the .so files got created in below locations-



1. /usr/lib64/libxml2.so

2. /usr/lib64/httpd/modules/mod_proxy_html.so

3. /usr/lib64/httpd/modules/mod_xml12enc.so



I copied the files 'mod_proxy_html.so' and 'mod_xml12enc.so' from the above folders into '/u03/apache/modules/'
directory. Then I put the below entries in '/u03/apache/conf/httpd.conf' -



LoadFile /usr/lib64/libxml2.so
LoadModule proxy_html_module modules/mod_proxy_html.so
LoadModule xml2enc_module modules/mod_xml2enc.so



But upon strating apache system gives error saying "httpd: Syntax error on line 150 of /u03/apache/conf/httpd.conf:
Cannot load modules/mod_proxy_html.so into server: /u03/apache/modules/mod_proxy_html.so:
undefined symbol: ap_log_perror"



Regards

Ayaskant

The information contained in this electronic message and any attachments to this message are
intended for the exclusive use of the addressee(s) and may contain proprietary, confidential
or privileged information. If you are not the intended recipient, you should not disseminate,
distribute or copy this e-mail. Please notify the sender immediately and destroy all copies
of this message and any attachments. 

WARNING: Computer viruses can be transmitted via email. The recipient should check this email
and any attachments for the presence of viruses. The company accepts no liability for any
damage caused by any virus transmitted by this email.

www.wipro.com

Mime
View raw message