httpd-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sinha, Vikas" <Vikas.Si...@intergraph.com>
Subject [users@httpd] Hot stand by not responding.
Date Mon, 31 Mar 2014 06:20:16 GMT
Hi All,

I am trying to setup a hot cluster with following configuration.

<VirtualHost *:8787>
    ServerName http://in-g-vsinha4
    ServerAlias in-g-vsinha4.com
                                   ProxyPass / balancer://hotcluster/
                                <Proxy balancer://hotcluster>
                                BalancerMember http://in-g-vsinha4:80
                                # The below is the hot standby
                                BalancerMember http://122.160.226.226:80 status=+H
                                ProxySet lbmethod=bytraffic
                                </Proxy>

        <Location /balancer-manager>
          SetHandler balancer-manager
          Require all granted
        </Location>

        <Directory "/Library/WebServer/Documents">
                   AllowOverride AuthConfig
         </Directory>
</VirtualHost>

Everything seems well when BalancerMember http://in-g-vsinha4:80 is up and running.

When BalancerMember http://in-g-vsinha4:80 is down I get

Service Temporary Unavailable!
The server is temporarily unable to service your request due to maintenance downtime or capacity
problems. Please try again later.
  Jakarta/ISAPI/isapi_redirector/1.2.37
As I understand BalancerMember http://122.160.226.226:80 status=+H which is a hot standby
is not able to respond due to some error in configuration.

I am using Apache 2.4.

Any help will be appreciated.

Mime
View raw message